summary refs log tree commit diff
path: root/gnu/packages/ccache.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-10-12 16:50:47 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-12 17:46:23 +0000
commita1eca979fb8da842e73c42f4f53be29b169810f2 (patch)
tree681c7283e412bb8a29c2531c4408b49c3e184764 /gnu/packages/ccache.scm
parent48d86a9ec6d8d2e97da2299ea41a03ef4cdaab83 (diff)
parent371aa5777a3805a3886f3feea5f1960fe3fe4219 (diff)
downloadguix-a1eca979fb8da842e73c42f4f53be29b169810f2.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen.
Diffstat (limited to 'gnu/packages/ccache.scm')
-rw-r--r--gnu/packages/ccache.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/ccache.scm b/gnu/packages/ccache.scm
index 77098658cf..44b0ef606a 100644
--- a/gnu/packages/ccache.scm
+++ b/gnu/packages/ccache.scm
@@ -31,37 +31,38 @@
 (define-public ccache
   (package
     (name "ccache")
-    (version "4.4")
+    (version "4.4.2")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://github.com/ccache/ccache/releases/download/v"
                            version "/ccache-" version ".tar.xz"))
        (sha256
-        (base32 "0qbmcs6c3m071vsd1ppa31r8s0dzpaw5y38z8ga1bz48rwpfl2xl"))))
+        (base32 "186b5lfbdd48cvbxqv2yh93pgr8lhahl1jzw00k2rmjzmbxwl04j"))))
     (build-system cmake-build-system)
     (native-inputs `(("perl" ,perl)     ; for test/run
                      ("which" ,(@ (gnu packages base) which))))
     (inputs `(("zlib" ,zlib)
               ("zstd" ,zstd "lib")))
     (arguments
-     '(;; Disable redis backend explicitly. Build system insists on present dependency
-       ;; or on explicit flag.
+     '( ;; The Redis backend must be explicitly disabled to build without Redis.
        #:configure-flags
        '("-DREDIS_STORAGE_BACKEND=OFF")
 
        #:phases
        (modify-phases %standard-phases
-         (add-before 'configure 'setup-tests
+         (add-before 'configure 'fix-shell
+           ;; Run early whilst we're still in the source directory.
            (lambda _
-             (substitute* '("unittest/test_hashutil.cpp" "test/suites/base.bash")
-               (("#!/bin/sh") (string-append "#!" (which "sh"))))
-             #t))
+             (substitute* (list "test/run"
+                                "test/suites/base.bash"
+                                "unittest/test_hashutil.cpp")
+               (("compgen -e") "env | cut -d= -f1")
+               (("#!/bin/sh") (string-append "#!" (which "sh"))))))
          (add-before 'check 'set-home
            ;; Tests require a writable HOME.
            (lambda _
-             (setenv "HOME" (getenv "TMPDIR"))
-             #t)))))
+             (setenv "HOME" (getenv "TMPDIR")))))))
     (home-page "https://ccache.dev/")
     (synopsis "Compiler cache")
     (description