summary refs log tree commit diff
path: root/gnu/packages/certs.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-26 10:02:30 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-27 09:30:16 -0500
commit18c38c18989aab28a654c9e546243603690cc75e (patch)
tree358da5c1db18f9aeacbda00998619135f3710e99 /gnu/packages/certs.scm
parentcfcead2e515c0dae02127e5a76496463898be6b6 (diff)
downloadguix-18c38c18989aab28a654c9e546243603690cc75e.tar.gz
gnu: nss-certs: Sync with the sources used for nss.
* gnu/packages/certs.scm (nss-certs)[version]: Reuse nss version.
[source]: Reuse nss source.
[phases]{install}: Adjust for the new NSS source files hierarchy.  Remove
trailing #t.
Diffstat (limited to 'gnu/packages/certs.scm')
-rw-r--r--gnu/packages/certs.scm21
1 files changed, 6 insertions, 15 deletions
diff --git a/gnu/packages/certs.scm b/gnu/packages/certs.scm
index b72d927c0d..1ea2536d8f 100644
--- a/gnu/packages/certs.scm
+++ b/gnu/packages/certs.scm
@@ -4,6 +4,7 @@
 ;;; Copyright © 2016, 2017 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -27,6 +28,7 @@
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system trivial)
   #:use-module (gnu packages)
+  #:use-module (gnu packages nss)
   #:use-module (gnu packages python)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages tls))
@@ -76,18 +78,8 @@
 (define-public nss-certs
   (package
     (name "nss-certs")
-    (version "3.59")
-    (source (origin
-              (method url-fetch)
-              (uri (let ((version-with-underscores
-                          (string-join (string-split version #\.) "_")))
-                     (string-append
-                      "https://ftp.mozilla.org/pub/mozilla.org/security/nss/"
-                      "releases/NSS_" version-with-underscores "_RTM/src/"
-                      "nss-" version ".tar.gz")))
-              (sha256
-               (base32
-                "096fs3z21r171q24ca3rq53p1389xmvqz1f2rpm7nlm8r9s82ag6"))))
+    (version (package-version nss))
+    (source (package-source nss))
     (build-system gnu-build-system)
     (outputs '("out"))
     (native-inputs
@@ -120,7 +112,7 @@
                        (cut display cert <>)))))
 
                (mkdir-p certsdir)
-               (with-directory-excursion "nss/lib/ckfw/builtins/"
+               (with-directory-excursion "lib/ckfw/builtins/"
                  ;; extract single certificates from blob
                  (invoke "certdata2pem.py" "certdata.txt")
                  ;; copy selected .pem files into the output
@@ -134,8 +126,7 @@
                  ;; "Usage error; try -help."
                  ;; This looks like a bug in openssl-1.0.2, but we can also
                  ;; switch into the target directory.
-                 (invoke "c_rehash" "."))
-               #t))))))
+                 (invoke "c_rehash" "."))))))))
 
     (synopsis "CA certificates from Mozilla")
     (description