summary refs log tree commit diff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-21 20:36:25 +0100
committerMarius Bakke <marius@gnu.org>2022-01-22 10:23:00 +0100
commit8830d9f900f3dc2107a0ce9541312579fa6ccb6e (patch)
tree1e381f3626d5012b6fe8631b3fe5a29739f187e5 /gnu/packages/check.scm
parentb62737097ca6c68bead5ae4e27d5098bb03e09cd (diff)
downloadguix-8830d9f900f3dc2107a0ce9541312579fa6ccb6e.tar.gz
gnu: python-pytest-asyncio: Update to 0.17.2.
* gnu/packages/check.scm (python-pytest-asyncio): Update to 0.17.2.
[arguments]: Specify setuptools-scm version.  Replace check phase.
[native-inputs]: Remove PYTHON-COVERAGE.  Add PYTHON-FLAKY and
PYTHON-SETUPTOOLS-SCM.
* gnu/packages/python-xyz.scm (python-tqdm, python-watchgod)[arguments]:
Specify asyncio_mode when running tests.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm21
1 files changed, 17 insertions, 4 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 481c0332cd..2dbb95c899 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1789,7 +1789,7 @@ executed.")
 (define-public python-pytest-asyncio
   (package
     (name "python-pytest-asyncio")
-    (version "0.15.1")
+    (version "0.17.2")
     (source
      (origin
        (method git-fetch)               ;for tests
@@ -1798,11 +1798,24 @@ executed.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "03drs4myv1ik79148xyhli37q6mp931jb14cz65n8qvls2zvvwgx"))))
+        (base32 "0sl0ckc23m40q6r2xcidsizrgqbbsfa7rwmr80fss359xsydf073"))))
     (build-system python-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'unpack 'pretend-version
+                 (lambda _
+                   (setenv "SETUPTOOLS_SCM_PRETEND_VERSION"
+                           #$(package-version this-package))))
+               (replace 'check
+                 (lambda* (#:key tests? #:allow-other-keys)
+                   (invoke "pytest" "-vv" "tests"))))))
     (native-inputs
-     (list python-coverage python-async-generator python-hypothesis
-           python-pytest))
+     (list python-async-generator
+           python-flaky
+           python-hypothesis
+           python-pytest
+           python-setuptools-scm))
     (home-page "https://github.com/pytest-dev/pytest-asyncio")
     (synopsis "Pytest support for asyncio")
     (description "Python asyncio code is usually written in the form of