summary refs log tree commit diff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-15 15:14:45 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-15 16:33:10 -0500
commita6f49177c5f24fd17ae12281a1878ff5b79b8b8e (patch)
tree8701c2c2a2cd6839a86e80d989b4d2ce8c394741 /gnu/packages/check.scm
parent9d44234960f66517c854a51c9bfae3a856924ba5 (diff)
downloadguix-a6f49177c5f24fd17ae12281a1878ff5b79b8b8e.tar.gz
gnu: python-hypothesmith: Update to 0.1.8.
* gnu/packages/check.scm (python-hypothesmith): Update to 0.1.8.
[propagated-inputs]: Replace python-hypothesmith-5.23 by python-hypothesmith.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 4f8d2f3d3e..373a604105 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1913,19 +1913,19 @@ seamlessly into your existing Python unit testing work flow.")
 (define-public python-hypothesmith
   (package
     (name "python-hypothesmith")
-    (version "0.1.2")
+    (version "0.1.8")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "hypothesmith" version))
        (sha256
         (base32
-         "09331sspknv459xcyn1k0lx5flqlc6gmnwp9370pfvg4kg1zmss6"))))
+         "02j101m5grjrbvrgjap17jsxd1hgawkylmyswcn33vf42mxh9zzr"))))
     (build-system python-build-system)
     (propagated-inputs
-     `(("python-hypothesis" ,python-hypothesis-5.23)
+     `(("python-hypothesis" ,python-hypothesis)
        ("python-lark-parser" ,python-lark-parser)
-       ("python-libcst" ,python-libcst)))
+       ("python-libcst" ,python-libcst-minimal)))
     (home-page "https://github.com/Zac-HD/hypothesmith")
     (synopsis "Strategies for generating Python programs")
     (description