summary refs log tree commit diff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-02-08 17:45:51 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-02-09 21:27:24 +0100
commitac63cf0a6995fb9de6121e648b401167895b2c9d (patch)
tree9723d68c3bc9d249d1e30760f8718884ee619418 /gnu/packages/check.scm
parent5b972c3256eff3588ad516b6ae64f2b948cac7c5 (diff)
downloadguix-ac63cf0a6995fb9de6121e648b401167895b2c9d.tar.gz
gnu: Remove python-flake8@3.5.
* gnu/packages/python-xyz.scm (python-flake8-3.5): Rename to ...
(python-flake8): ... this.  Update to 3.6.0.  Remove previous variant.
[arguments]: Remove phases 'delete-broken-test' and 'fix-problem-with-pycodestyle'.
[properties]: Adjust for renamed variable.
(python2-flake8-3.5): Rename to ...
(python2-flake8): ... this.  Remove previous variable.
* gnu/packages/check.scm (python-hypothesis)[native-inputs]: Adjust accordingly.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm3
1 files changed, 1 insertions, 2 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index afb3b96aba..02ee9b136b 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1456,8 +1456,7 @@ instantly.")
                 "0fvq4mfybm129l978war86mcshkn28dkrxw7lr8549zr9ywvik1c"))))
     (build-system python-build-system)
     (native-inputs
-     `(;; FIXME: Change to python-flake8 in the next rebuild cycle.
-       ("python-flake8" ,python-flake8-3.5)
+     `(("python-flake8" ,python-flake8)
        ("python-pytest" ,python-pytest-bootstrap)))
     (propagated-inputs
      `(("python-attrs" ,python-attrs-bootstrap)