summary refs log tree commit diff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorng0 <ng0@infotropique.org>2017-09-04 11:59:46 +0000
committerLudovic Courtès <ludo@gnu.org>2017-09-14 14:07:25 +0200
commitc61794cf451f84df532dadbc0660c5fef92d337b (patch)
tree05c11dc2b3b20c6fd07ab67b6ba6eb40a132a107 /gnu/packages/check.scm
parent205441eb0eb27e5fdbd36f436b55b02f5429883b (diff)
downloadguix-c61794cf451f84df532dadbc0660c5fef92d337b.tar.gz
gnu: Add cpputest.
* gnu/packages/check.scm (cpputest): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 198bb81f8e..fcfedb99aa 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -8,6 +8,7 @@
 ;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
 ;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;; Copyright © 2017 Kei Kebreau <kkebreau@posteo.net>
+;;; Copyright © 2017 ng0 <ng0@infotropique.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -270,3 +271,26 @@ normally do not detect.  The goal is to detect only real errors in the code
 discovery, death tests, assertions, parameterized tests and XML test report
 generation.")
     (license bsd-3)))
+
+(define-public cpputest
+  (package
+    (name "cpputest")
+    (version "3.8")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/cpputest/cpputest/releases/download/v"
+                           version "/cpputest-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0mk48xd3klyqi7wf3f4wn4zqxxzmvrhhl32r25jzrixzl72wq7f8"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("googletest" ,googletest)))
+    (home-page "https://cpputest.github.io/")
+    (synopsis "Unit testing and mocking framework for C/C++")
+    (description
+     "CppUTest is a C/C++ based unit xUnit test framework.  It is written in
+C++ but is used in C and C++ projects and frequently used in embedded systems
+but it works for any C/C++ project.")
+    (license bsd-3)))