summary refs log tree commit diff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-09 15:18:39 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-08-09 15:18:39 +0300
commit36cb285d61f99bbaa8f6e84e0ddeac3f788a2e16 (patch)
tree9984277df78e29c912d3acb603325a67ea9aabfa /gnu/packages/check.scm
parent23d0007e9a5b20ad0c9e380c34b24dcdef57cf90 (diff)
downloadguix-36cb285d61f99bbaa8f6e84e0ddeac3f788a2e16.tar.gz
gnu: python-pylint: Update to 2.9.6.
* gnu/packages/check.scm (python-pylint): Update to 2.9.6.
[arguments]: Remove field.
[native-inputs]: Remove python-tox.
[propagated-inputs]: Remove python-six.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm25
1 files changed, 4 insertions, 21 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index adc81fffd5..9cd53725ba 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2163,42 +2163,25 @@ statements in the module it tests.")
 (define-public python-pylint
   (package
     (name "python-pylint")
-    (version "2.6.0")
+    (version "2.9.6")
     (source
      (origin
        (method git-fetch)
        (uri (git-reference
              (url "https://github.com/PyCQA/pylint")
-             (commit (string-append "pylint-" version))))
+             (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0ws3dz3wm49brnhhfm7v75zq202pwlwfbi3njdd69aqxq912x15z"))))
+        (base32 "15yw69v1cj6zkndk60c2g0dgl0khh8bfm1lrwhjffpdjfc7nkc9a"))))
     (build-system python-build-system)
-    (arguments
-     `(#:tests? #t
-       #:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               ;; The following failing tests are skipped (see:
-               ;; https://github.com/PyCQA/pylint/issues/4068).
-               (invoke "pytest" "-k"
-                       (string-append
-                        "not unused_typing_imports "
-                        "and not star_needs_assignment_target_py35 "
-                        "and not regression_property_no_member_2641 "
-                        "and not missing_kwoa_py3"))))))))
     (native-inputs
      `(("python-pytest" ,python-pytest)
        ("python-pytest-benchmark" ,python-pytest-benchmark)
-       ("python-pytest-runner" ,python-pytest-runner)
-       ("python-tox" ,python-tox)))
+       ("python-pytest-runner" ,python-pytest-runner)))
     (propagated-inputs
      `(("python-astroid" ,python-astroid)
        ("python-isort" ,python-isort)
        ("python-mccabe" ,python-mccabe)
-       ("python-six" ,python-six)
        ("python-toml" ,python-toml)))
     (home-page "https://github.com/PyCQA/pylint")
     (synopsis "Python source code analyzer which looks for coding standard