summary refs log tree commit diff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2020-03-27 13:57:00 +0100
committerLudovic Courtès <ludo@gnu.org>2020-04-02 00:06:26 +0200
commitb27a0dd46c22ad004a3ef9f1246c58a1de452714 (patch)
treeda32839d1c088fe484d82e1d5371cc98c8d3d73a /gnu/packages/check.scm
parentecceef27c8913654714b091243263b9e590e3f8a (diff)
downloadguix-b27a0dd46c22ad004a3ef9f1246c58a1de452714.tar.gz
gnu: Add python-pytest-forked
* gnu/packages/check.scm (python-pytest-forked): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index c5a886ecae..2cfaddbc5f 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1026,6 +1026,31 @@ result back.")
 timeout has been exceeded.")
     (license license:expat)))
 
+(define-public python-pytest-forked
+  (package
+    (name "python-pytest-forked")
+    (version "1.1.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pytest-forked" version))
+       (sha256
+        (base32
+         "000i4q7my2fq4l49n8idx2c812dql97qv6qpm2vhrrn9v6g6j18q"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-pytest" ,python-pytest)))
+    (native-inputs
+     `(("python-setuptools-scm" ,python-setuptools-scm)))
+    (home-page
+     "https://github.com/pytest-dev/pytest-forked")
+    (synopsis
+     "Run tests in isolated forked subprocesses")
+    (description
+     "Pytest plugin which will run each test in a subprocess and will report if
+a test crashed the process.")
+    (license license:expat)))
+
 (define-public python-scripttest
   (package
     (name "python-scripttest")