summary refs log tree commit diff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-14 22:22:21 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-15 16:33:08 -0500
commitbe7061cea30b59676fc473d6bd4a56a0f2fbd7cf (patch)
treeff185971c629b50987fe0b422959a92c46d4d7df /gnu/packages/check.scm
parent9837bc5e35948884b734922462eba4d6b8855a37 (diff)
downloadguix-be7061cea30b59676fc473d6bd4a56a0f2fbd7cf.tar.gz
gnu: python-pytest: Propagate python-iniconfig, python-toml.
Based on a reading of the install_requires field of its setup.cfg file.

* gnu/packages/check.scm (python-pytest)[native-inputs]: Move
python-iniconfig...
[propagated-inputs]: ... to here.  Add python-toml.  Remove
python-atomicwrites, apparently only required on the win32 platform.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 36c0805d62..24cf6a2588 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -67,6 +67,7 @@
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages python-build)
   #:use-module (gnu packages python-web)
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages time)
@@ -907,19 +908,19 @@ standard library.")
                           " and not test_color_yes"))
                  (format #t "test suite not run~%")))))))
     (propagated-inputs
-     `(("python-atomicwrites" ,python-atomicwrites)
-       ("python-attrs" ,python-attrs-bootstrap)
+     `(("python-attrs" ,python-attrs-bootstrap)
+       ("python-iniconfig" ,python-iniconfig)
        ("python-more-itertools" ,python-more-itertools)
        ("python-packaging" ,python-packaging-bootstrap)
        ("python-pluggy" ,python-pluggy)
        ("python-py" ,python-py)
        ("python-six" ,python-six-bootstrap)
+       ("python-toml" ,python-toml)
        ("python-wcwidth" ,python-wcwidth)))
     (native-inputs
      `(;; Tests need the "regular" bash since 'bash-final' lacks `compgen`.
        ("bash" ,bash)
        ("python-hypothesis" ,python-hypothesis)
-       ("python-iniconfig" ,python-iniconfig)
        ("python-nose" ,python-nose)
        ("python-mock" ,python-mock)
        ("python-pytest" ,python-pytest-bootstrap)