summary refs log tree commit diff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2023-03-26 19:43:34 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-29 13:23:46 -0400
commitec628ef1c87e34dc6b2a5d7c8a95f7d20acc974e (patch)
treea55e9edfd974dffe09852678a50a45354ed26c8f /gnu/packages/check.scm
parentd495b504440836e22afc881371ede2ed30f5372f (diff)
downloadguix-ec628ef1c87e34dc6b2a5d7c8a95f7d20acc974e.tar.gz
gnu: python-pytest-7.1: Depend on python-pluggy-next.
* gnu/packages/check.scm (python-pytest-7.1)[propagated-inputs]: Replace
  python-pluggy with python-pluggy-next.

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 0c8777a074..40c7ae0175 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1322,11 +1322,14 @@ and many external plugins.")
          "0f8c31v5r2kgjixvy267n0nhc4xsy65g3n9lz1i1377z5pn5ydjg"))))
     (arguments
      (substitute-keyword-arguments (package-arguments python-pytest)
-      ((#:phases phases #~%standard-phases)
+       ((#:phases phases #~%standard-phases)
         #~(modify-phases #$phases
             (add-before 'build 'pretend-version
               (lambda _
-                (setenv "SETUPTOOLS_SCM_PRETEND_VERSION" #$version)))))))))
+                (setenv "SETUPTOOLS_SCM_PRETEND_VERSION" #$version)))))))
+    (propagated-inputs
+     (modify-inputs (package-propagated-inputs python-pytest)
+       (replace "python-pluggy" python-pluggy-next)))))
 
 (define-public python-pytest-bootstrap
   (package