summary refs log tree commit diff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-06-18 15:21:14 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-06-18 15:32:56 +0200
commit4e24e442f2c9629edf08bef30ec98959da950189 (patch)
tree6ce99d96843e3187b0d0420c85e4b94f5479dc9a /gnu/packages/check.scm
parenteed81080dc6f552e381971ec11cec5de0c58a58d (diff)
downloadguix-4e24e442f2c9629edf08bef30ec98959da950189.tar.gz
gnu: python-freezegun: Update to 0.3.12.
* gnu/packages/check.scm (python-freezegun): Update to 0.3.12.
[native-inputs]: Remove PYTHON-NOSE and PYTHON-COVERAGE.  Add PYTHON-PYTEST.
[arguments]: Use "pytest" instead of "nosetests" for running tests.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 82391ac5e1..e24f2713b4 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2043,18 +2043,17 @@ create data based on random numbers and yet remain repeatable.")
 (define-public python-freezegun
   (package
     (name "python-freezegun")
-    (version "0.3.11")
+    (version "0.3.12")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "freezegun" version))
        (sha256
-        (base32 "1nh0fzqjwg88n57k3qa8mxnmiwrr7lqyd5xvc96qn5g8zcxv8fg8"))))
+        (base32 "1rx57v8ryjncjimg8hys9kx1r3rknvwcl4y340g20jn0sf69qk9a"))))
     (build-system python-build-system)
     (native-inputs
      `(("python-mock" ,python-mock)
-       ("python-nose" ,python-nose)
-       ("python-coverage" ,python-coverage)))
+       ("python-pytest" ,python-pytest)))
     (propagated-inputs
      `(("python-six" ,python-six)
        ("python-dateutil" ,python-dateutil)))
@@ -2065,7 +2064,7 @@ create data based on random numbers and yet remain repeatable.")
          ;; package does not include the Makefile.
          (replace 'check
            (lambda _
-             (invoke "nosetests" "./tests/"))))))
+             (invoke "pytest" "-vv"))))))
     (home-page "https://github.com/spulec/freezegun")
     (synopsis "Test utility for mocking the datetime module")
     (description