summary refs log tree commit diff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorTimo Wilken <guix@twilken.net>2023-02-26 20:13:20 +0100
committerLeo Famulari <leo@famulari.name>2023-02-26 14:29:59 -0500
commitec8c7370dfd66136f7cb517d31fa6fda31e2cb74 (patch)
treeecb4a6ed7fa230dba4feb719deca2411fcf9eefa /gnu/packages/check.scm
parent1a550c93e54aa2ba39cd12af5b0348019e315dd4 (diff)
downloadguix-ec8c7370dfd66136f7cb517d31fa6fda31e2cb74.tar.gz
gnu: Add go-github-com-robfig-cron-1.2.
* gnu/packages/check.scm (go-github-com-robfig-cron-1.2):
  New variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 0866558ac2..c928d11f64 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -42,6 +42,7 @@
 ;;; Copyright © 2022 Sharlatan Hellseher <sharlatanus@gmail.com>
 ;;; Copyright © 2022 jgart <jgart@dismail.de>
 ;;; Copyright © 2023 Luis Felipe López Acevedo <luis.felipe.la@protonmail.com>
+;;; Copyright © 2023 Timo Wilken <guix@twilken.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1028,6 +1029,24 @@ C++ but is used in C and C++ projects and frequently used in embedded systems
 but it works for any C/C++ project.")
     (license license:bsd-3)))
 
+;; Required by actionlint. The version of `go-github-com-robfig-cron'
+;; packaged in Guix is newer and changed some error messages, causing
+;; unit tests in actionlint to fail.
+(define-public go-github-com-robfig-cron-1.2
+  (package
+    (inherit go-github-com-robfig-cron)
+    (name "go-github-com-robfig-cron")
+    (version "1.2.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/robfig/cron")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0nv31m3940d9kf38lw2zs4hpj435bdi9mmim098rb3n4l07qrvva"))))))
+
 (define-public python-parameterized
   (package
     (name "python-parameterized")