summary refs log tree commit diff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-12 12:06:32 +0200
committerMarius Bakke <marius@gnu.org>2022-09-09 17:03:55 +0200
commit9912024c34e49d954cc50bcf62edb078e28938e8 (patch)
tree3256bf8346edaeb24fe80554f94a7e5ba997738d /gnu/packages/check.scm
parent85009bedebdd5cb4d1c9f88db294217b642f0504 (diff)
downloadguix-9912024c34e49d954cc50bcf62edb078e28938e8.tar.gz
gnu: python-pytest: Remove input labels.
* gnu/packages/check.scm (python-pytest)[propagated-inputs, native-inputs]:
Remove labels.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm36
1 files changed, 18 insertions, 18 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 08069e7daa..25643b462d 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1005,25 +1005,25 @@ standard library.")
                           " and not test_color_yes"))
                  (format #t "test suite not run~%")))))))
     (propagated-inputs
-     `(("python-attrs" ,python-attrs-bootstrap)
-       ("python-iniconfig" ,python-iniconfig)
-       ("python-more-itertools" ,python-more-itertools)
-       ("python-packaging" ,python-packaging-bootstrap)
-       ("python-pluggy" ,python-pluggy)
-       ("python-py" ,python-py)
-       ("python-six" ,python-six-bootstrap)
-       ("python-toml" ,python-toml)
-       ("python-wcwidth" ,python-wcwidth)))
+     (list python-attrs-bootstrap
+           python-iniconfig
+           python-more-itertools
+           python-packaging-bootstrap
+           python-pluggy
+           python-py
+           python-six-bootstrap
+           python-toml
+           python-wcwidth))
     (native-inputs
-     `(;; Tests need the "regular" bash since 'bash-final' lacks `compgen`.
-       ("bash" ,bash)
-       ("python-hypothesis" ,python-hypothesis)
-       ("python-nose" ,python-nose)
-       ("python-mock" ,python-mock)
-       ("python-pytest" ,python-pytest-bootstrap)
-       ("python-setuptools-scm" ,python-setuptools-scm)
-       ("python-toml" ,python-toml)
-       ("python-xmlschema" ,python-xmlschema)))
+     (list ;; Tests need the "regular" bash since 'bash-final' lacks `compgen`.
+           bash
+           python-hypothesis
+           python-nose
+           python-mock
+           python-pytest-bootstrap
+           python-setuptools-scm
+           python-toml
+           python-xmlschema))
     (home-page "https://docs.pytest.org/en/latest/")
     (synopsis "Python testing library")
     (description