summary refs log tree commit diff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-12-25 00:41:08 +0000
committerTobias Geerinckx-Rice <me@tobias.gr>2017-12-25 02:01:00 +0100
commita431b035008e5fe1ea844f743ff993cb56c7795e (patch)
tree362a4b04b5ecf2a230495ae1b32581911d88e388 /gnu/packages/check.scm
parent8c2781f005a725c60a4be36094fc79e3bd6de492 (diff)
downloadguix-a431b035008e5fe1ea844f743ff993cb56c7795e.tar.gz
gnu: python-rednose: Update to 1.2.3.
* gnu/packages/check.scm (python-rednose): Update to 1.2.3.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm13
1 files changed, 2 insertions, 11 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index f8e7e53ec5..3c971ad839 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1591,24 +1591,15 @@ JSON APIs with Behave.")
 (define-public python-rednose
   (package
     (name "python-rednose")
-    (version "1.2.1")
+    (version "1.2.3")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "rednose" version))
         (sha256
           (base32
-            "0b0bsna217lr1nykyhl5fgjly15zhdvqd4prg4wy1zrgfv7al6m0"))))
+            "11x5nx5b4wdq04s7vj1gcdl07jvvkfb37p0r5lg773gr5rr8mj6h"))))
     (build-system python-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'fix-deps
-           (lambda _
-             ;; See <https://github.com/JBKahn/rednose/issues/12>
-             (substitute* "setup.py"
-               (("python-termstyle") "termstyle"))
-             #t)))))
     (propagated-inputs
      `(("python-colorama" ,python-colorama)
        ("python-termstyle" ,python-termstyle)))