summary refs log tree commit diff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-17 17:45:39 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-17 22:24:04 -0500
commite40dfcfcb1bcfa15355b076714897709fa4e1fb2 (patch)
treeeaf1241ed6e945c6263249ebc2395d5303dcd505 /gnu/packages/check.scm
parentf91d1c30194a9168d0f30d35a024e44f7066d6e3 (diff)
downloadguix-e40dfcfcb1bcfa15355b076714897709fa4e1fb2.tar.gz
gnu: python-aiohttp: Update to 3.8.1.
* gnu/packages/check.scm (python-pytest-6.1): Delete package.
* gnu/packages/python-web.scm (python-aiohttp): Update to 3.8.1.
[source]: Adjust snippet and comment it out with a TODO comment.
[phases]{cythonize}: Fix indentation.
{check}: Use 'when' for the TESTS? condition.
Delete the test_proxy_functional.py test file.
Skip tests requiring networking.  Run tests in parallel with xdist.
[propagated-inputs]: Add python-aiosignal.  Remove python-attrs.
{python-chardet}: Replace by...
{python-charset-normalizer}: ... this.
Add python-frozenlist.
[native-inputs]: Use the regular python-pytest package.
Add python-pytest-xdist.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm11
1 files changed, 0 insertions, 11 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index d380b8fa80..8b90929b4b 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1004,17 +1004,6 @@ and many external plugins.")
     (license license:expat)
     (properties `((python2-variant . ,(delay python2-pytest))))))
 
-(define-public python-pytest-6.1
-  (package
-    (inherit python-pytest)
-    (version "6.1.2")
-    (source
-      (origin
-        (method url-fetch)
-        (uri (pypi-uri "pytest" version))
-        (sha256
-         (base32 "0gl2sdm322vzmsh5k4f8kj9raiq2y7kdinnca4m45ifvii5fk9y0"))))))
-
 (define-public python-pytest-6 python-pytest)
 
 ;; Pytest 4.x are the last versions that support Python 2.