summary refs log tree commit diff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorSarah Morgensen <iskarian@mgsn.dev>2021-09-19 16:18:22 -0700
committerLeo Famulari <leo@famulari.name>2021-12-08 13:35:34 -0500
commit93c7a5103d240dfc5ba4b39969faf198e7a350fa (patch)
tree0ee914e8546a600ff77fc4594cc1bf9648295d98 /gnu/packages/check.scm
parent9bac41c2b8e7be5ab713402591ceeb32c635c214 (diff)
downloadguix-93c7a5103d240dfc5ba4b39969faf198e7a350fa.tar.gz
gnu: Remove go-gopkg.in-check.v1.
This package is a duplicate of go-gopkg-in-check-v1 in golang.scm,
has no binaries, and has no dependents, so remove it.

* gnu/packages/check.scm (go-gopkg.in-check.v1): Remove variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm26
1 files changed, 0 insertions, 26 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 1f9cc26913..4928f02bfd 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -566,32 +566,6 @@ and it supports a very flexible form of test discovery.")
 has been designed to be fast, light and unintrusive.")
     (license license:expat)))
 
-(define-public go-gopkg.in-check.v1
-  (let ((commit "788fd78401277ebd861206a03c884797c6ec5541")
-        (revision "1"))
-    (package
-      (name "go-gopkg.in-check.v1")
-      (version (git-version "0.0.0" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://github.com/go-check/check")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "0v3bim0j375z81zrpr5qv42knqs0y2qv2vkjiqi5axvb78slki1a"))))
-      (build-system go-build-system)
-      (arguments
-       '(#:import-path "gopkg.in/check.v1"))
-      (propagated-inputs
-       `(("go-github-com-kr-pretty" ,go-github-com-kr-pretty)))
-      (synopsis "Rich testing extension for Go's testing package")
-      (description
-       "@code{check} is a rich testing extension for Go's testing package.")
-      (home-page "https://github.com/go-check/check")
-      (license license:bsd-2))))
-
 (define-public go-github.com-smartystreets-gunit
   (package
     (name "go-github.com-smartystreets-gunit")