summary refs log tree commit diff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-01-31 13:43:32 +0000
committerChristopher Baines <mail@cbaines.net>2018-02-01 20:21:24 +0000
commit7952804cecf670b4b0d6f75df6f86d64c5b65e71 (patch)
tree05484f137e00f9a0ab14f7c48930f571f8059a4b /gnu/packages/check.scm
parentbee301254996a84e29923e1af3fe652151e9d513 (diff)
downloadguix-7952804cecf670b4b0d6f75df6f86d64c5b65e71.tar.gz
gnu: Add go-github.com-smartystreets-assertions.
* gnu/packages/check.scm (go-github.com-smartystreets-assertions): New
  variable.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 69d5b7a382..b26deda8a3 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -338,6 +338,31 @@ test) much simpler.")
     (home-page "https://github.com/smartystreets/gunit")
     (license license:expat)))
 
+(define-public go-github.com-smartystreets-assertions
+  (package
+    (name "go-github.com-smartystreets-assertions")
+    (version "1.8.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/smartystreets/assertions")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1j0adgbykl55rf2945g0n5bmqdsnjcqlx5dcmpfh4chki43hiwg9"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/smartystreets/assertions"))
+    (native-inputs
+     `(("go-github.com-smartystreets-gunit" ,go-github.com-smartystreets-gunit)))
+    (synopsis "Assertions for testing with Go")
+    (description
+     "The @code{assertions} package provides convinient assertion functions
+for writing tests in Go.")
+    (home-page "https://github.com/smartystreets/assertions")
+    (license license:expat)))
+
 (define-public googletest
   (package
     (name "googletest")