summary refs log tree commit diff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-07-24 00:11:01 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-07-28 15:52:29 +0200
commita9ae30b78ed591e8212a4b918024c771f0896a4f (patch)
tree5a3568c52767f1cdfdd105b78cc6412f1f82742e /gnu/packages/check.scm
parent1166b9c795e3762ece2623143ae2fe0984b4a158 (diff)
downloadguix-a9ae30b78ed591e8212a4b918024c771f0896a4f.tar.gz
gnu: python-pytest: Update to 3.6.3.
* gnu/packages/check.scm (python-pytest): Update to 3.6.3.
[propagated-inputs]: Add PYTHON-ATOMICWRITES.
[native-inputs]: Add PYTHON-INVOKE.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index b2a0ecce48..134e640344 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -619,14 +619,14 @@ standard library.")
 (define-public python-pytest
   (package
     (name "python-pytest")
-    (version "3.5.0")
+    (version "3.6.3")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "pytest" version))
        (sha256
         (base32
-         "1q832zd07zak2lyxbycxjydh0jp7y3hvawjqzlvra6aghz8r3r7s"))))
+         "0lnppwpz5i06sdhzv5b2j4x2f42mil38nx1l0kmnzvibdikwhlq4"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -644,7 +644,8 @@ standard library.")
                                line)))
              #t)))))
     (propagated-inputs
-     `(("python-attrs" ,python-attrs-bootstrap)
+     `(("python-atomicwrites" ,python-atomicwrites)
+       ("python-attrs" ,python-attrs-bootstrap)
        ("python-more-itertools" ,python-more-itertools)
        ("python-pluggy" ,python-pluggy)
        ("python-py" ,python-py)
@@ -653,6 +654,7 @@ standard library.")
      `(;; Tests need the "regular" bash since 'bash-final' lacks `compgen`.
        ("bash" ,bash)
        ("python-hypothesis" ,python-hypothesis)
+       ("python-invoke" ,python-invoke)   ;XXX: not needed for >3.6.3
        ("python-nose" ,python-nose)
        ("python-mock" ,python-mock)
        ("python-setuptools-scm" ,python-setuptools-scm)))