summary refs log tree commit diff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-04-07 22:07:14 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-05-02 00:38:53 +0200
commit56e95d54d209c2428f970d65d9b27ae4168449ad (patch)
tree18c73644dfe0b390ad548e3d4c4fb7a8e815c711 /gnu/packages/check.scm
parentf1e9999b5f69e4534a0f74acf3080b0e34bdcc98 (diff)
downloadguix-56e95d54d209c2428f970d65d9b27ae4168449ad.tar.gz
gnu: python-pytest: Update to 4.4.1.
* gnu/packages/check.scm (python-pytest): Update to 4.4.1.
[arguments]: Enable previously failing tests.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm12
1 files changed, 3 insertions, 9 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 6103f8e3f7..ef6b29f17d 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -686,14 +686,14 @@ standard library.")
 (define-public python-pytest
   (package
     (name "python-pytest")
-    (version "4.3.1")
+    (version "4.4.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "pytest" version))
        (sha256
         (base32
-         "08q58ad8vaxyb57ll8m611yb4xwzzhp09kxafmyqrrps6cnalbjr"))))
+         "1xcmic8wzaj00rn1lg4ib4prh2f4lzpiaadk35qlv8hcny1j505p"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -707,13 +707,7 @@ standard library.")
                       " and not test_argcomplete"
                       ;; This test tries to override PYTHONPATH, and
                       ;; subsequently fails to locate the test libraries.
-                      " and not test_collection"
-                      ;; These tests fail when run in verbose mode:
-                      ;; <https://github.com/pytest-dev/pytest/issues/4879>.
-                      " and not test_dont_rewrite_if_hasattr_fails"
-                      " and not test_len"
-                      " and not test_custom_repr"
-                      " and not test_name")))))))
+                      " and not test_collection")))))))
     (propagated-inputs
      `(("python-atomicwrites" ,python-atomicwrites)
        ("python-attrs" ,python-attrs-bootstrap)