summary refs log tree commit diff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-06-20 23:08:16 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-06-20 23:08:16 +0200
commit651478aa18a3f575d3b4cc14166a15a1c45b0f61 (patch)
tree87c27dc9eff3d321f7ad4a622b110c517856a104 /gnu/packages/check.scm
parent71c08ee60bb3f62bac0614888fb62405f7a388ab (diff)
parent9a2e5fe5fdcc6ea848ceeefa0f70147dfb360639 (diff)
downloadguix-651478aa18a3f575d3b4cc14166a15a1c45b0f61.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index e24f2713b4..4bb608bd8f 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -925,6 +925,27 @@ result back.")
 (define-public python2-pytest-xdist
   (package-with-python2 python-pytest-xdist))
 
+(define-public python-pytest-timeout
+  (package
+    (name "python-pytest-timeout")
+    (version "1.3.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pytest-timeout" version))
+       (sha256
+        (base32
+         "1cczcjhw4xx5sjkhxlhc5c1bkr7x6fcyx12wrnvwfckshdvblc2a"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-pytest" ,python-pytest)))
+    (home-page "http://bitbucket.org/pytest-dev/pytest-timeout/")
+    (synopsis "Plugin for py.test to abort hanging tests")
+    (description
+     "This package provides a py.test plugin that aborts hanging tests after a
+timeout has been exceeded.")
+    (license license:expat)))
+
 (define-public python-scripttest
   (package
     (name "python-scripttest")