summary refs log tree commit diff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-11-18 11:39:09 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-11-18 11:42:23 +0200
commit45a2346f329935bd6837e5fa3eca6232ef694242 (patch)
tree35e276fe1985c70148cb82539c7ae7cdc53a68c6 /gnu/packages/check.scm
parente005ddc223683f030d4dc64588968e474328eb65 (diff)
downloadguix-45a2346f329935bd6837e5fa3eca6232ef694242.tar.gz
gnu: python-pytest-localserver: Fix test suite.
* gnu/packages/check.scm (python-pytest-localserver): Replace custom
'check phase.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 24a9902434..d85295206a 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1351,11 +1351,11 @@ the last py.test invocation.")
                "08f06rvj31wqf0vgmd1waya87r7vy6x8ck48lxl3dxy83q5gcam7"))))
     (build-system python-build-system)
     (arguments
-      `(#:phases (modify-phases %standard-phases
+     '(#:phases
+       (modify-phases %standard-phases
          (replace 'check
            (lambda _
-             (invoke "py.test" "--genscript=runtests.py")
-             (invoke "py.test"))))))
+             (invoke "py.test" "-v"))))))
     (native-inputs
      `(("python-pytest" ,python-pytest)
        ("python-requests" ,python-requests)