summary refs log tree commit diff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-10 22:04:58 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:40 -0400
commit476ae98d0bd0be0cddea27edbf99c65c0c798cdb (patch)
treeb868e01fe04af87a443a5b9b8975108fca803399 /gnu/packages/check.scm
parent86be766874a198611f70c1883106cee42361d114 (diff)
downloadguix-476ae98d0bd0be0cddea27edbf99c65c0c798cdb.tar.gz
gnu: pylint: Run tests in parallel.
* gnu/packages/check.scm (python-pylint)
[phases]{check}: Add the '-n' option to use xdist with pytest.
[native-inputs]: Add python-pytest-xdist.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index b7a5a9bd46..005a3bde7c 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2532,9 +2532,10 @@ statements in the module it tests.")
                (delete-file "tests/primer/test_primer_external.py")
                (delete-file "tests/testutils/test_package_to_lint.py")
                (setenv "HOME" "/tmp")
-               (invoke "pytest" "-k" "test_functional")))))))
+               (invoke "pytest" "-k" "test_functional"
+                       "-n" (number->string (parallel-job-count)))))))))
     (native-inputs
-     (list python-pytest))
+     (list python-pytest python-pytest-xdist))
     (propagated-inputs
      (list python-astroid
            python-isort