summary refs log tree commit diff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-11 16:14:55 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-08-11 16:14:55 +0300
commit5037b08b934a68b297b0db484006d2d3ce026adb (patch)
tree4aed9ef815d94562e748eb27e9e26e3303292a0c /gnu/packages/check.scm
parent02fbd89f2b69ebb1793261026c4471280048335f (diff)
downloadguix-5037b08b934a68b297b0db484006d2d3ce026adb.tar.gz
gnu: python-fixtures: Honor tests? in the check phase.
* gnu/packages/check.scm (python-fixtures)[arguments]: Adjust 'check
phase to honor #:tests.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index eb20d0fd54..f6f225c2f7 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1611,9 +1611,10 @@ python-fixtures package instead.")
      '(#:phases
        (modify-phases %standard-phases
          (replace 'check
-           (lambda _
-             (invoke "python" "-m" "testtools.run"
-                     "fixtures.test_suite"))))))
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "python" "-m" "testtools.run"
+                       "fixtures.test_suite")))))))
     (propagated-inputs
      ;; Fixtures uses pbr at runtime to check versions, etc.
      `(("python-pbr" ,python-pbr)