summary refs log tree commit diff
path: root/gnu/packages/chemistry.scm
diff options
context:
space:
mode:
authorDavid Elsing <david.elsing@posteo.net>2022-10-13 21:04:20 +0000
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-10-15 12:05:15 +0200
commit697f0c8a6a234ae0d6a057ba7e11819539862da8 (patch)
treedcee400d75a6b2e4b61211b245e0b709dc65caea /gnu/packages/chemistry.scm
parentf1707153984f17facac2ba67befe893e29632f7c (diff)
downloadguix-697f0c8a6a234ae0d6a057ba7e11819539862da8.tar.gz
gnu: Add coordgenlibs.
* gnu/packages/chemistry.scm (coordgenlibs): New variable.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/chemistry.scm')
-rw-r--r--gnu/packages/chemistry.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index 8ccf2ccf4b..d005be5310 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -771,3 +771,30 @@ of the algorithms, the calculations give identical results.")
     (synopsis "Maestro file parser")
     (description "maeparser is a parser for Schrodinger Maestro files.")
     (license license:expat)))
+
+(define-public coordgenlibs
+  (package
+    (name "coordgenlibs")
+    (version "3.0.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/schrodinger/coordgenlibs/")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0d09x3v38i9y184bml020bq7xizdrdwng38qmdxlplzfhqkjdidv"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list
+      #:configure-flags
+      #~(list "-DCOORDGEN_RIGOROUS_BUILD=OFF"
+              "-DCOORDGEN_USE_MAEPARSER=ON")))
+    (inputs (list boost maeparser))
+    (home-page "https://github.com/schrodinger/coordgenlibs/")
+    (synopsis "2D molecule coordinate generation")
+    (description "@code{coordgenlibs} contains algorithms to generate 2D
+coordinates of molecules including macrocycles and metal complexes.  It has an
+emphasis on quality rather than speed.")
+    (license license:bsd-3)))