summary refs log tree commit diff
path: root/gnu/packages/chez.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2022-03-08 20:25:20 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-03-08 20:53:44 +0100
commitb8fc9169515ef1a6d6037c84e30ad308e5418b6f (patch)
treec0aac061c5a0be0731c340cf3105202a2d1200b9 /gnu/packages/chez.scm
parent0a7c355e0a11f800880a4d576e9cd40e5345c91d (diff)
downloadguix-b8fc9169515ef1a6d6037c84e30ad308e5418b6f.tar.gz
gnu: stex-bootstrap: Guard against unsupported systems.
The current implementation of nix-system->chez-machine et al. is rather
brittle and fails in unexpected ways.  In the meantime while a better
replacement is being built, prevent falsy return values from causing errors,
such as a failing “guix pull”.  See <https://issues.guix.gnu.org/54292>.

* gnu/packages/chez.scm (stex-bootstrap)[maybe-compile]: Use and=> to only
call chez-machine->threaded if nix-system->chez-machine returns a truthy
value.
Diffstat (limited to 'gnu/packages/chez.scm')
-rw-r--r--gnu/packages/chez.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index b3aadf3a78..d47225dbe5 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -604,8 +604,8 @@ Chez Scheme.")))
                         (define makefile
                           (string-append (getcwd) "/Makefile"))
                         (define machine
-                          #$(chez-machine->threaded
-                             (nix-system->chez-machine)))
+                          #$(and=> (nix-system->chez-machine)
+                                   chez-machine->threaded))
                         (with-directory-excursion
                             (search-input-directory outputs "/lib/stex")
                           (invoke "make"