summary refs log tree commit diff
path: root/gnu/packages/chez.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-15 17:29:17 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-16 19:02:05 +0100
commit24a43551d0767dac9659f3e9233a688d1cde2225 (patch)
treed0a99765c84f8bba354c45767af0afbe7c0dfba4 /gnu/packages/chez.scm
parent88c85a940335f6cd5472f9dff7ade29753ea5353 (diff)
downloadguix-24a43551d0767dac9659f3e9233a688d1cde2225.tar.gz
gnu: chez-irregex: Don't use unstable tarball.
* gnu/packages/chez.scm (chez-irregex)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/chez.scm')
-rw-r--r--gnu/packages/chez.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index 04371c7413..4a7fe0bfca 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -464,13 +464,13 @@ Chez Scheme.")
     (version "0.9.4")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append
-             "https://github.com/fedeinthemix/chez-irregex/archive"
-             "/v" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/fedeinthemix/chez-irregex.git")
+             (commit (string-append "v" version))))
        (sha256
-        (base32 "0ywy5syaw549a58viz68dmgnv756ic705rcnlqxgjq27lnaim53b"))
-       (file-name (string-append name "-" version ".tar.gz"))))
+        (base32 "0jh6piylw545j81llay9wfivgpv6lcnwd81gm4w17lkasslir50q"))
+       (file-name (git-file-name name version))))
     (build-system gnu-build-system)
     (inputs
      `(("chez-matchable" ,chez-matchable))) ; for tests