summary refs log tree commit diff
path: root/gnu/packages/chez.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-16 15:25:32 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-16 19:02:05 +0100
commit95b4f7ca7aa6391af10fef637c95f42c4a01debb (patch)
treef2df736c5e2e61b8d0a02798d01d5770bb9e6689 /gnu/packages/chez.scm
parent24a43551d0767dac9659f3e9233a688d1cde2225 (diff)
downloadguix-95b4f7ca7aa6391af10fef637c95f42c4a01debb.tar.gz
gnu: chez-scheme: Fix ‘install-doc’ phase.
* gnu/packages/chez.scm (chez-cheme)[arguments]: Find ‘installsh’.
Remove some unnecessary code.
Diffstat (limited to 'gnu/packages/chez.scm')
-rw-r--r--gnu/packages/chez.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index 4a7fe0bfca..8476eefe12 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -1,7 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2016 Federico Beffa <beffa@fbengineering.ch>
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -179,17 +179,18 @@
          ;; Installation of the documentation requires a running "chez".
          (add-after 'install 'install-doc
            (lambda* (#:key inputs outputs #:allow-other-keys)
-             (let ((bin (string-append (assoc-ref outputs "out") "/bin"))
-                   (doc (string-append (assoc-ref outputs "doc")
+             (let ((doc (string-append (assoc-ref outputs "doc")
                                        "/share/doc/" ,name "-" ,version)))
-               (setenv "HOME" (getcwd))
-               (setenv "PATH" (string-append (getenv "PATH") ":" bin))
-               (with-directory-excursion "stex"
-                 (system* "make" (string-append "BIN=" bin)))
                (system* "make" "docs")
                (with-directory-excursion "csug"
                  (substitute* "Makefile"
-                   (("/tmp/csug9") doc))
+                   ;; The ‘installdir=’ can't be overruled on the command line.
+                   (("/tmp/csug9") doc)
+                   ;; $m is the ‘machine type’, e.g. ‘ta6le’ on x86_64, but is
+                   ;; set incorrectly for some reason, e.g. to ‘a6le’ on x86_64.
+                   ;; Avoid the whole mess by running the (machine-independent)
+                   ;; ‘installsh’ script at its original location.
+                   (("\\$m/installsh") "makefiles/installsh"))
                  (system* "make" "install")
                  (install-file "csug.pdf" doc))
                (with-directory-excursion "release_notes"