summary refs log tree commit diff
path: root/gnu/packages/chez.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2023-08-23 20:08:06 -0400
committerEfraim Flashner <efraim@flashner.co.il>2023-09-08 09:05:58 +0300
commitbb20ab942e03cd9309e3ecbef22ea2f2946810db (patch)
tree69d3dd2e9682365194d66a2d82e5be0d5b938841 /gnu/packages/chez.scm
parentbce0fe8293a15331ed8b4e9a76354988f10e1ef5 (diff)
downloadguix-bb20ab942e03cd9309e3ecbef22ea2f2946810db.tar.gz
gnu: chez-scheme-for-racket-bootstrap-bootfiles: Remove workaround.
Architecture autodetection in rktboot was fixed upstream, and the fix is
included in racket-backport-8.10-rktboot.patch for Guix. This commit
goes beyond reverting b4fbeae3d90a5d0f8146441772436df2eb471491: the
upstream fix also supports 'pbarch' machine types, so we never need to
supply a '--machine' argument to rktboot.

* gnu/packages/chez.scm (chez-scheme-for-racket-bootstrap-bootfiles)
[arguments]: Change 'build' phase to never use '--machine' for rktboot.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/chez.scm')
-rw-r--r--gnu/packages/chez.scm8
1 files changed, 1 insertions, 7 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index e5694ec1cf..3f53beac1a 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -691,13 +691,7 @@ source.")))
                       #~(invoke
                          (search-input-file (or native-inputs inputs)
                                             "/opt/racket-vm/bin/racket")
-                         "../rktboot/main.rkt"
-                         ;; Temporary handling of builds on non-x86 architectures,
-                         ;; see https://github.com/racket/racket/issues/3948
-                         ;; Autodetect in rktboot only addresses x86 archs, so far.
-                         #$@(let ((m (or (racket-cs-native-supported-system?)
-                                         (nix-system->pbarch-machine-type))))
-                              #~("--machine" #$m))))))))))))
+                         "../rktboot/main.rkt"))))))))))
     (supported-systems
      (package-supported-systems chez-scheme-for-racket))
     (home-page "https://github.com/racket/ChezScheme")