summary refs log tree commit diff
path: root/gnu/packages/chez.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-16 16:41:57 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-16 19:02:06 +0100
commitfbf41223604a5c29ff08cbe9738bc8c51286cf30 (patch)
treed51dfa04db32f91af8cdcafe948fe50b0c125d04 /gnu/packages/chez.scm
parent2f1ab477729497beb5897f0e2a59e9dbb57470b1 (diff)
downloadguix-fbf41223604a5c29ff08cbe9738bc8c51286cf30.tar.gz
gnu: stex: Don't use unstable tarball.
* gnu/packages/chez.scm (stex)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
(chez-scheme)[arguments]: Adjust expected source directory name.
Diffstat (limited to 'gnu/packages/chez.scm')
-rw-r--r--gnu/packages/chez.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index 5cf3231f30..d8c914804e 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -52,12 +52,12 @@
 (define stex
   (let ((version "1.2.1"))
     (origin
-      (method url-fetch)
-      (uri (string-append
-            "https://github.com/dybvig/stex/archive"
-            "/v" version ".tar.gz"))
-      (sha256 (base32 "03pl3f668h24dn51vccr1sj5lsba9zq3j37bnxjvdadcdaj4qy5z"))
-      (file-name (string-append "stex-" version ".tar.gz")))))
+      (method git-fetch)
+      (uri (git-reference
+            (url "https://github.com/dybvig/stex.git")
+            (commit (string-append "v" version))))
+      (sha256 (base32 "1jiawhhqnsj42hzmlbq5xby3iarhf8vhiqs0kg1a0zg5jsn6cf8n"))
+      (file-name (git-file-name "stex" version)))))
 
 (define-public chez-scheme
   (package
@@ -143,7 +143,7 @@
                        (delete-file-recursively new-name)
                        (invoke "mv" orig-name new-name)))
                     `((,nanopass "source" "nanopass")
-                      (,stex "stex-1.2.1" "stex")))
+                      (,stex "source" "stex")))
                ;; The Makefile wants to download and compile "zlib".  We patch
                ;; it to use the one from our 'zlib' package.
                (substitute* "configure"