summary refs log tree commit diff
path: root/gnu/packages/chez.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-12-09 04:35:58 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2017-12-09 14:13:16 +0100
commitf88c1c5d89d19f5a68d42f028eb01292e8301e2f (patch)
treeff8e4717a4116efbcac60770fb9ce2262871893e /gnu/packages/chez.scm
parent83b9d121a78e6bb4e3d57474d3e01d0a3c4dd5e9 (diff)
downloadguix-f88c1c5d89d19f5a68d42f028eb01292e8301e2f.tar.gz
gnu: chez-scheme: Update to 9.5.
* gnu/packages/chez.scm (chez-scheme): Update to 9.5.
[arguments]: Add ‘patch-broken-documentation’ phase.
Diffstat (limited to 'gnu/packages/chez.scm')
-rw-r--r--gnu/packages/chez.scm15
1 files changed, 12 insertions, 3 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index b532057605..4b5b8e8bc7 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2016 Federico Beffa <beffa@fbengineering.ch>
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -61,14 +62,14 @@
 (define-public chez-scheme
   (package
     (name "chez-scheme")
-    (version "9.4")
+    (version "9.5")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://github.com/cisco/ChezScheme/archive/"
                            "v" version ".tar.gz"))
        (sha256
-        (base32 "0lprmpsjg2plc6ykgkz482zyvhkzv6gd0vnar71ph21h6zknyklz"))
+        (base32 "135991hspq0grf26pvl2lkwhp92yz204h6rgiwyym0x6v0xzknd1"))
        (file-name (string-append "chez-scheme-" version ".tar.gz"))))
     (build-system gnu-build-system)
     (inputs
@@ -104,7 +105,15 @@
          (add-after 'unpack 'patch-processor-detection
            (lambda _ (substitute* "configure"
                        (("uname -a") "uname -m"))
-             #t))
+                   #t))
+         (add-after 'unpack 'patch-broken-documentation
+           (lambda _
+             ;; Work around an oversight in the 9.5 release tarball that causes
+             ;; building the documentation to fail. This should be fixed in the
+             ;; next one; see <https://github.com/cisco/ChezScheme/issues/209>.
+             (substitute* "csug/copyright.stex"
+               (("\\\\INSERTREVISIONMONTHSPACEYEAR" )
+                "October 2017"))))     ; tarball release date
          ;; Adapt the custom 'configure' script.
          (replace 'configure
            (lambda* (#:key inputs outputs #:allow-other-keys)