summary refs log tree commit diff
path: root/gnu/packages/chicken.scm
diff options
context:
space:
mode:
authorraingloom <raingloom@riseup.net>2020-10-13 09:55:42 +0200
committerLudovic Courtès <ludo@gnu.org>2020-12-03 16:18:43 +0100
commit7dd7bab48a172a2ebf30b725a3da1e1268a388b9 (patch)
tree5871066575594408b505fbdc351d60549f56e25d /gnu/packages/chicken.scm
parenta0e2a3e30c65f5eb29923e661b8e5669cc2d0163 (diff)
downloadguix-7dd7bab48a172a2ebf30b725a3da1e1268a388b9.tar.gz
gnu: Add chicken-test.
* gnu/packages/chicken.scm (chicken-test): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/chicken.scm')
-rw-r--r--gnu/packages/chicken.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/chicken.scm b/gnu/packages/chicken.scm
index 76ba0ab7f5..442dff78e9 100644
--- a/gnu/packages/chicken.scm
+++ b/gnu/packages/chicken.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2020 Ekaitz Zarraga <ekaitz@elenq.tech>
 ;;; Copyright © 2020 Evan Hanson <evhan@foldling.org>
+;;; Copyright © 2020 raingloom <raingloom@riseup.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -20,8 +21,11 @@
 (define-module (gnu packages chicken)
   #:use-module (gnu packages)
   #:use-module (guix packages)
+  #:use-module (guix build-system chicken)
   #:use-module (guix build-system gnu)
   #:use-module (guix download)
+  #:use-module (guix git-download)
+  #:use-module (guix svn-download)
   #:use-module (gnu packages commencement)
   #:use-module ((guix licenses)
                 #:prefix license:))
@@ -72,3 +76,28 @@
 produces portable and efficient C, supports almost all of the R5RS Scheme
 language standard, and includes many enhancements and extensions.")
     (license license:bsd-3)))
+
+(define-public chicken-test
+  (package
+    (name "chicken-test")
+    (version "1.1")
+    (source
+     (origin
+       (method svn-fetch)
+       (uri (svn-reference
+             (url (string-append "https://code.call-cc.org/svn/chicken-eggs/"
+                                 "release/5/test/tags/" version))
+             (revision 39263)
+             (user-name "anonymous")
+             (password "")))
+       (file-name (string-append "chicken-test-" version "-checkout"))
+       (sha256
+        (base32
+         "14i91cxsn6hjkx6kqf7i9syck73cw71jik61jmhg87vpxx5kfnzx"))))
+    (build-system chicken-build-system)
+    (arguments '(#:egg-name "test"))
+    (home-page "https://wiki.call-cc.org/eggref/5/test")
+    (synopsis "Yet another testing utility")
+    (description
+     "This package provides a simple testing utility for CHICKEN Scheme.")
+    (license license:bsd-3)))