summary refs log tree commit diff
path: root/gnu/packages/chromium.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2023-02-20 21:17:48 +0100
committerAndreas Enge <andreas@enge.fr>2023-02-25 15:27:06 +0100
commitd1260b9c401d6dabec7f8f33f984e33d99aaf981 (patch)
treef565f32b758d981286940afce5d1467595731fff /gnu/packages/chromium.scm
parentcb3332808f42beb4c08970ed792875ee145b715c (diff)
downloadguix-d1260b9c401d6dabec7f8f33f984e33d99aaf981.tar.gz
gnu: ungoogled-chromium: Adapt patches.
* gnu/packages/chromium.scm (%debian-revision): Move to a later release
for Debian patches.
(%ungoogled-origin): Update hash accordingly.
(%debian-patches): Enable "fixes/clang-and-gcc11.patch".
Diffstat (limited to 'gnu/packages/chromium.scm')
-rw-r--r--gnu/packages/chromium.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/chromium.scm b/gnu/packages/chromium.scm
index e321ae3fe6..47153e3531 100644
--- a/gnu/packages/chromium.scm
+++ b/gnu/packages/chromium.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2019-2023 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
+;;; Copyright © 2023 Andreas Enge <andreas@enge.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -318,7 +319,9 @@
 
 (define %chromium-version "109.0.5414.119")
 (define %ungoogled-revision (string-append %chromium-version "-1"))
-(define %debian-revision "debian/102.0.5005.61-1")
+(define %debian-revision "debian/103.0.5060.53-1")
+  ;; This is the first release supporting openjpeg@2.5 in openjpeg.patch;
+  ;; it still includes jsoncpp.patch, which also appears to be needed.
 (define %arch-revision "a0b214b3bdfbc7ee3d9004a70494a2b9e3da2c80")
 
 (define %ungoogled-origin
@@ -342,7 +345,7 @@
                                 ((_ version) version))))
     (sha256
      (base32
-      "1ln6r1qzlr7dsgvcbssvvc34my4mpkwv9hmvlb2dhjncs7isp65j"))))
+      "0bmbp1y0cykcbjhvsk330d11f7qnwmapcwxv76vdbl8cjfb6h60w"))))
 
 (define (origin-file origin file)
   (computed-file
@@ -355,7 +358,8 @@
 
 (define %debian-patches
   (map debian-patch
-       '("system/jsoncpp.patch"
+       '("fixes/clang-and-gcc11.patch"
+         "system/jsoncpp.patch"
          "system/zlib.patch"
          "system/openjpeg.patch")))