summary refs log tree commit diff
path: root/gnu/packages/chromium.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-04-28 17:59:07 +0200
committerMarius Bakke <marius@gnu.org>2021-04-28 17:59:32 +0200
commit8dcbd8a374f21f478f0059d4d62e364897e6e667 (patch)
tree142303840dbf37e58b698007b60cb23bd09af07e /gnu/packages/chromium.scm
parentcc036035146263e6544bc94f941771912bfe3c1d (diff)
downloadguix-8dcbd8a374f21f478f0059d4d62e364897e6e667.tar.gz
gnu: ungoogled-chromium: Update to 90.0.4430.93.
* gnu/packages/patches/ungoogled-chromium-system-nspr.patch,
gnu/packages/patches/ungoogled-chromium-system-opus.patch: Delete files.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/chromium.scm (%preserved-third-party-files): Adjust for 90.
(debian-patch): Make REVISION optional, default to %DEBIAN-REVISION.
(%chromium-version): New variable.
(%ungoogled-revision): Set to 90.0.4430.85-1-11-g3184907.
(%debian-revision): Set to debian/90.0.4430.85-1.
(%debian-patches): Add more patches; update hashes.
(%ungoogled-origin): Update hash.
(%guix-patches): Remove obsolete patches.
(libvpx/chromium): Update to 1.9.0-147-g61edec1ef.
(ungoogled-chromium)[version]: Base on %CHROMIUM-REVISION and the last
component of %UNGOOGLED-REVISION, a 'git describe --long' style ID.
[arguments]: Add build_with_flite_lib in #:configure-flags.  Add openjpeg
substitution in #:phases.
Diffstat (limited to 'gnu/packages/chromium.scm')
-rw-r--r--gnu/packages/chromium.scm77
1 files changed, 52 insertions, 25 deletions
diff --git a/gnu/packages/chromium.scm b/gnu/packages/chromium.scm
index 835e9e2050..ea7b242788 100644
--- a/gnu/packages/chromium.scm
+++ b/gnu/packages/chromium.scm
@@ -150,9 +150,14 @@
     "third_party/devtools-frontend/src/third_party/pyjson5" ;ASL2.0
     "third_party/devtools-frontend/src/third_party/typescript" ;ASL2.0
     "third_party/dom_distiller_js" ;BSD-3
+    "third_party/eigen3" ;MPL2.0
     "third_party/emoji-segmenter" ;ASL2.0
+    "third_party/farmhash" ;Expat
+    "third_party/fdlibm" ;non-copyleft
+    "third_party/fft2d" ;non-copyleft
     "third_party/flatbuffers" ;ASL2.0
     "third_party/fusejs" ;ASL2.0
+    "third_party/gemmlowp" ;ASL2.0
     "third_party/google_input_tools" ;ASL2.0
     "third_party/google_input_tools/third_party/closure_library" ;ASL2.0
     "third_party/google_input_tools/third_party/closure_library/third_party/closure" ;Expat
@@ -171,8 +176,10 @@
     "third_party/libXNVCtrl" ;Expat
     "third_party/libaddressinput" ;ASL2.0
     "third_party/libaom" ;BSD-2 or "Alliance for Open Media Patent License 1.0"
+    "third_party/libaom/source/libaom/third_party/fastfeat" ;BSD-3
     "third_party/libaom/source/libaom/third_party/vector" ;Expat
     "third_party/libaom/source/libaom/third_party/x86inc" ;ISC
+    "third_party/libgav1" ;ASL2.0
     "third_party/libgifcodec" ;MPL1.1/GPL2+/LGPL2.1+, BSD-3, BSD-2
     "third_party/libjingle_xmpp" ;BSD-3
     "third_party/libphonenumber" ;ASL2.0
@@ -190,6 +197,7 @@
     "third_party/libwebm" ;BSD-3
     "third_party/libxml/chromium" ;BSD-3
     "third_party/libyuv" ;BSD-3
+    "third_party/libzip" ;BSD-3
     "third_party/lottie" ;Expat
     "third_party/lss" ;BSD-3
     "third_party/mako" ;Expat
@@ -211,6 +219,7 @@
     "third_party/pdfium/third_party/agg23" ;Expat
     "third_party/pdfium/third_party/base" ;BSD-3
     "third_party/pdfium/third_party/bigint" ;Public domain, BSD-3
+    "third_party/pdfium/third_party/libtiff" ;non-copyleft
     "third_party/pdfium/third_party/skia_shared" ;BSD-3
     "third_party/pdfium/third_party/freetype/include/pstables.h" ;FreeType
     "third_party/perfetto" ;ASL2.0
@@ -228,6 +237,7 @@
     ;; ABI relies on libstdc++ internals.  See build/linux/unbundle/re2.gn.
     "third_party/re2" ;BSD-3
     "third_party/rnnoise" ;BSD-3
+    "third_party/ruy" ;ASL2.0
     "third_party/s2cellid" ;ASL2.0
     "third_party/schema_org" ;CC-BY-SA3.0
     "third_party/securemessage" ;ASL2.0
@@ -247,9 +257,15 @@
     "third_party/swiftshader/third_party/subzero" ;NCSA
     "third_party/swiftshader/third_party/SPIRV-Headers" ;X11-style
     "third_party/tcmalloc/chromium" ;BSD-3
+    "third_party/tensorflow-text" ;ASL2.0
+    "third_party/tflite" ;ASL2.0
+    "third_party/tflite/src/third_party/eigen3" ;MPL2.0
+    "third_party/tflite/src/third_party/fft2d" ;ASL2.0
+    "third_party/tflite-support" ;ASL2.0
     "third_party/ukey2" ;ASL2.0
     "third_party/usb_ids" ;BSD-3
     "third_party/usrsctp" ;BSD-2
+    "third_party/utf" ;Expat
     "third_party/vulkan-deps" ;ASL2.0, BSD-3, Expat
     "third_party/vulkan_memory_allocator" ;Expat
     "third_party/wayland/protocol" ;Expat
@@ -269,6 +285,7 @@
     "third_party/widevine/cdm/widevine_cdm_version.h" ;BSD-3
     "third_party/widevine/cdm/widevine_cdm_common.h" ;BSD-3
     "third_party/woff2" ;ASL2.0
+    "third_party/wuffs" ;ASL2.0
     "third_party/xcbproto" ;X11
     "third_party/xdg-utils" ;Expat
 
@@ -293,7 +310,7 @@
   ;; run the Blink performance tests, just remove everything to save ~70MiB.
   '("third_party/blink/perf_tests"))
 
-(define (debian-patch name revision hash)
+(define* (debian-patch name hash #:optional (revision %debian-revision))
   (origin
     (method url-fetch)
     (uri (string-append "https://salsa.debian.org/chromium-team/chromium/-/raw/"
@@ -303,37 +320,35 @@
                   (string-append "ungoogled-chromium-" category "-" name))))
     (sha256 (base32 hash))))
 
-(define %ungoogled-revision "89.0.4389.114-1")
-(define %debian-revision "debian/84.0.4147.105-1")
+(define %chromium-version "90.0.4430.93")
+(define %debian-revision "debian/90.0.4430.85-1")
+(define %ungoogled-revision "90.0.4430.85-1-11-g3184907")
 
 (define %debian-patches
-  (list (debian-patch "system/zlib.patch" %debian-revision
-                      "09vqgs37w9ycc7par14wa7rnvmg9bm0z9pqg6fyl3iqvpghyjyr4")
-        (debian-patch "system/openjpeg.patch" %debian-revision
-                      "0zd6v5njx1pc7i0y6mslxvpx5j4cq01mmyx55qcqx8qzkm0gm48j")))
+  (list (debian-patch "fixes/missing-includes.patch"
+                      "1f0drxp1cy76g71rkkzxxbwixn03yn9b0q22vb0mb6h2qk6cw92q")
+        (debian-patch "fixes/nomerge.patch"
+                      "0lybs2b5gk08j8cr6vjrs9d3drd7qfw013z2r0y00by8dnpm74i3")
+        (debian-patch "system/nspr.patch"
+                      "1gdirn1k1i841l8zp8xgr95kl16b5nx827am9rcxj8sfkm8hgkn3")
+        (debian-patch "system/zlib.patch"
+                      "0j313bd3q8qc065j60x97dckrfgbwl4qxc8jhz33iihvv4lwziwv")
+        (debian-patch "system/openjpeg.patch"
+                      "048405xh84pys0kky81vlqhaxjyxvcql4py217z01qxiv991zxaj")))
 
 (define %ungoogled-origin
   (origin
     (method git-fetch)
     (uri (git-reference (url "https://github.com/Eloston/ungoogled-chromium")
                         (commit %ungoogled-revision)))
-    (file-name (git-file-name "ungoogled-chromium"
-                              (if (= 40 (string-length %ungoogled-revision))
-                                  (string-take %ungoogled-revision 7)
-                                  %ungoogled-revision)))
+    (file-name (git-file-name "ungoogled-chromium" %ungoogled-revision))
     (sha256
      (base32
-      "0cr2i51gxhgl55c8f9w0ra3m5q2dk03sf7p2qn4bqq1l1l72hw6s"))))
+      "18xfwgkw3xarxcgnzvyv70h4icyqh3k8lfx6fvhp7fsr6x20sai0"))))
 
 (define %guix-patches
   (list (local-file
          (assume-valid-file-name
-          (search-patch "ungoogled-chromium-system-nspr.patch")))
-        (local-file
-         (assume-valid-file-name
-          (search-patch "ungoogled-chromium-system-opus.patch")))
-        (local-file
-         (assume-valid-file-name
           (search-patch "ungoogled-chromium-extension-search-path.patch")))))
 
 ;; This is a source 'snippet' that does the following:
@@ -415,7 +430,7 @@
 (define libvpx/chromium
   (package
     (inherit libvpx)
-    (version "1.9.0-104-gb5d77a48d")
+    (version "1.9.0-147-g61edec1ef")
     (source (origin
               (inherit (package-source libvpx))
               (uri (git-reference
@@ -424,7 +439,7 @@
               (file-name (git-file-name "libvpx" version))
               (sha256
                (base32
-                "07nkpx8myw5nd4bkaj6l4wr5ipk2c6lg9cwirz0i5qbr659051rk"))))))
+                "0mw13y7j2lg8jj3alm9367c3b40b6s218fdz3nn1m2k85c78wzr7"))))))
 
 ;; 'make-ld-wrapper' can only work with an 'ld' executable, so we need
 ;; this trick to make it wrap 'lld'.
@@ -454,17 +469,19 @@
 (define-public ungoogled-chromium
   (package
     (name "ungoogled-chromium")
-    (version %ungoogled-revision)
+    (version (string-append %chromium-version "-0."
+                            (match (string-split %ungoogled-revision #\-)
+                              ((version revision commits g+short)
+                               (string-drop g+short 1)))))
     (synopsis "Graphical web browser")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://commondatastorage.googleapis.com"
                                   "/chromium-browser-official/chromium-"
-                                  (string-drop-right %ungoogled-revision 2)
-                                  ".tar.xz"))
+                                  %chromium-version ".tar.xz"))
               (sha256
                (base32
-                "007df9p78bbmk3iyfi8qn57mmn68qqrdhx6z8n2hl8ksd7lspw7j"))
+                "0zimr975vp0v12zz1nqjwag3f0q147wrmdhpzgi4yf089rgwfbjk"))
               (modules '((guix build utils)))
               (snippet (force ungoogled-chromium-snippet))))
     (build-system gnu-build-system)
@@ -506,6 +523,9 @@
              "enable_widevine=false"
              ;; Disable type-checking for the Web UI to avoid a Java dependency.
              "enable_js_type_check=false"
+             ;; Disable code using TensorFlow until it has been scrutinized
+             ;; by the ungoogled project.
+             "build_with_tflite_lib=false"
 
              ;; Define a custom toolchain that simply looks up CC, AR and
              ;; friends from the environment.
@@ -565,7 +585,13 @@
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'patch-stuff
-           (lambda _
+           (lambda* (#:key inputs #:allow-other-keys)
+             (let ((openjpeg (assoc-ref inputs "openjpeg")))
+               (substitute* "third_party/pdfium/BUILD.gn"
+                 ;; This include path is added by Debians openjpeg patch.
+                 (("/usr/include/openjpeg")
+                  (string-append openjpeg "/include/openjpeg"))))
+
              (substitute*
                  '("base/process/launch_posix.cc"
                    "base/third_party/dynamic_annotations/dynamic_annotations.c"
@@ -735,6 +761,7 @@
                                       "chrome_200_percent.pak"
                                       "resources.pak"
                                       "v8_context_snapshot.bin"
+
                                       ;; Chromium ships its own libGL
                                       ;; implementation called ANGLE.
                                       "libEGL.so" "libGLESv2.so"))