summary refs log tree commit diff
path: root/gnu/packages/chromium.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-06-25 14:23:59 +0200
committerMarius Bakke <marius@gnu.org>2020-06-26 01:54:00 +0200
commite6db8912fdec8b33e39c03b5e3b3268df12648ab (patch)
tree93066a2f4b8faeef0c42c574c76515384825f3d5 /gnu/packages/chromium.scm
parent7eb8ae5f6c2496facff617fbebe89961ef573ccc (diff)
downloadguix-e6db8912fdec8b33e39c03b5e3b3268df12648ab.tar.gz
gnu: ungoogled-chromium: Remove all Blink performance tests.
* gnu/packages/chromium.scm (%blacklisted-files): New variable.
(ungoogled-chromium-snippet): Adjust accordingly.
Diffstat (limited to 'gnu/packages/chromium.scm')
-rw-r--r--gnu/packages/chromium.scm19
1 files changed, 12 insertions, 7 deletions
diff --git a/gnu/packages/chromium.scm b/gnu/packages/chromium.scm
index a0ba5ac9c9..ac45befe44 100644
--- a/gnu/packages/chromium.scm
+++ b/gnu/packages/chromium.scm
@@ -248,6 +248,12 @@
     "v8/third_party/inspector_protocol" ;BSD-3
     "v8/third_party/v8/builtins")) ;PSFL
 
+(define %blacklisted-files
+  ;; 'third_party/blink/perf_tests/resources/svg/HarveyRayner.svg' carries a
+  ;; nonfree license according to LICENSES in the same directory.  As we don't
+  ;; run the Blink performance tests, just remove everything to save ~24MiB.
+  '("third_party/blink/perf_tests"))
+
 (define %chromium-version "83.0.4103.116")
 (define %ungoogled-revision "f08ce8b3f1300ef0750b5d6bf967b9cbbfd9a56d")
 (define %debian-revision "debian/81.0.4044.92-1")
@@ -340,13 +346,6 @@
            "PATH" '("bin")
            (list #+patch #+python-wrapper #+xz))
 
-          (format #t "Removing non-free file...~%")
-          (force-output)
-          ;; This file has a CC-BY-NC clause according to LICENSES from
-          ;; the same directory, making it non-free.
-          (delete-file
-           "third_party/blink/perf_tests/svg/resources/HarveyRayner.svg")
-
           ;; Apply patches before running the ungoogled scripts because
           ;; domain substitution may break some of the patches.
           (format #t "Applying assorted build fixes...~%")
@@ -374,6 +373,12 @@
                     "domain_regex.list" "-f" "domain_substitution.list"
                     "-c" "/tmp/domainscache.tar.gz" chromium-dir))
 
+          ;; Run after the ungoogled scripts to avoid interfering with
+          ;; patches or file lists.
+          (format #t "Removing blacklisted files...~%")
+          (force-output)
+          (for-each delete-file-recursively '#$%blacklisted-files)
+
           (format #t "Pruning third party files...~%")
           (force-output)
           (apply invoke (string-append #+python-2 "/bin/python")