summary refs log tree commit diff
path: root/gnu/packages/ci.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2022-01-09 18:04:56 +0100
committerMathieu Othacehe <othacehe@gnu.org>2022-01-09 18:04:56 +0100
commit9fd4f4b09cc0495d6b1418f171ff738a1086cc00 (patch)
tree7439c3e504349c8ebe7e0ec279475b22a84c0fc6 /gnu/packages/ci.scm
parentf76d07f027b4c4596a25842c81282d6a8c50442f (diff)
downloadguix-9fd4f4b09cc0495d6b1418f171ff738a1086cc00.tar.gz
gnu: cuirass: Remove trailing #t.
* gnu/packages/ci.scm (cuirass): Remove them.
Diffstat (limited to 'gnu/packages/ci.scm')
-rw-r--r--gnu/packages/ci.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/ci.scm b/gnu/packages/ci.scm
index a3a8a9195b..57aa778afe 100644
--- a/gnu/packages/ci.scm
+++ b/gnu/packages/ci.scm
@@ -114,14 +114,12 @@
              (lambda* (#:key inputs #:allow-other-keys)
                (let ((pg (assoc-ref inputs "ephemeralpg"))
                      (path (getenv "PATH")))
-                 (setenv "PATH" (string-append pg "/bin:" path))
-                 #t)))
+                 (setenv "PATH" (string-append pg "/bin:" path)))))
            ;; Disable the remote tests that require a Guix daemon connection.
            (add-before 'check 'disable-remote-tests
              (lambda _
                (substitute* "Makefile.am"
-                 (("tests/remote.scm") ""))
-               #t))
+                 (("tests/remote.scm") ""))))
            (add-after 'install 'wrap-program
              (lambda* (#:key inputs outputs #:allow-other-keys)
                ;; Wrap the 'cuirass' command to refer to the right modules.
@@ -165,8 +163,7 @@
                  (wrap-program (string-append out "/bin/cuirass")
                    `("PATH" ":" prefix (,(string-append out "/bin")))
                    `("GUILE_LOAD_PATH" ":" prefix (,mods))
-                   `("GUILE_LOAD_COMPILED_PATH" ":" prefix (,objs)))
-                 #t))))))
+                   `("GUILE_LOAD_COMPILED_PATH" ":" prefix (,objs)))))))))
       (inputs
        (list guile-3.0-latest
              guile-avahi