summary refs log tree commit diff
path: root/gnu/packages/ci.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-05-26 00:11:45 +0200
committerLudovic Courtès <ludo@gnu.org>2022-05-26 11:41:05 +0200
commitdcb7ce1eb6911f9d503e7cd2bfe380058cee956b (patch)
tree28f965a9d5709ca19806e91cc65ea2ad5713a27b /gnu/packages/ci.scm
parent4e13ee4b573f1829fbf41147febac9ca8b919034 (diff)
downloadguix-dcb7ce1eb6911f9d503e7cd2bfe380058cee956b.tar.gz
gnu: cuirass: Depend on an older Guix snapshot.
Works around <https://issues.guix.gnu.org/55441#12>.

* gnu/packages/package-management.scm (guix-for-cuirass): New variable.
* gnu/packages/ci.scm (cuirass)[inputs]: Use it.
Diffstat (limited to 'gnu/packages/ci.scm')
-rw-r--r--gnu/packages/ci.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/ci.scm b/gnu/packages/ci.scm
index ab421fe870..9cd2f6884e 100644
--- a/gnu/packages/ci.scm
+++ b/gnu/packages/ci.scm
@@ -164,7 +164,14 @@
              ;; FIXME: this is propagated by "guile-git", but it needs to be among
              ;; the inputs to add it to GUILE_LOAD_PATH.
              guile-bytestructures
-             guix))
+
+             ;; FIXME: The 'cuirass evaluate' command is multithreaded, but it
+             ;; uses 'open-inferior', which calls 'primitive-fork', thus
+             ;; potentially creating child processes that deadlock.  To work
+             ;; around that, use the last revision of Guix where
+             ;; 'open-inferior' was using 'open-pipe*' rather than
+             ;; 'primitive-fork'.  See <https://issues.guix.gnu.org/55441>.
+             guix-for-cuirass))
       (native-inputs
        (list autoconf automake pkg-config texinfo ephemeralpg))
       (native-search-paths