summary refs log tree commit diff
path: root/gnu/packages/cluster.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-28 16:38:15 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-29 15:25:24 +0200
commit36de28ffddd5f09852db7c534c48e71e25f3557b (patch)
treebdc84784ef6361469eae3dc1b8200364bd3a1a47 /gnu/packages/cluster.scm
parent7cd2fa9525e056616acc5f7e2d77c3a06a81b891 (diff)
downloadguix-36de28ffddd5f09852db7c534c48e71e25f3557b.tar.gz
gnu: keepalived: Update to 2.0.4.
* gnu/packages/cluster.scm (keepalived): Update to 2.0.4.
[arguments]: Remove ‘patch-configure’ phase (bug fixed in 2.0.3).
Diffstat (limited to 'gnu/packages/cluster.scm')
-rw-r--r--gnu/packages/cluster.scm12
1 files changed, 3 insertions, 9 deletions
diff --git a/gnu/packages/cluster.scm b/gnu/packages/cluster.scm
index 7cfd04f008..6d508f1c93 100644
--- a/gnu/packages/cluster.scm
+++ b/gnu/packages/cluster.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2018 Sou Bunnbu <iyzsong@member.fsf.org>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -30,7 +31,7 @@
 (define-public keepalived
   (package
     (name "keepalived")
-    (version "2.0.1")
+    (version "2.0.4")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -38,18 +39,11 @@
                     version ".tar.gz"))
               (sha256
                (base32
-                "0hp8i56zkf0398bmpi32a85f05cv2fy9wizkdfbxk7gav4z6yx18"))))
+                "0qf46bfxv4w7qx7d73qq26pp72cvbyfjvna3hxn208vynvapalh0"))))
     (build-system gnu-build-system)
     (arguments
      '(#:phases
        (modify-phases %standard-phases
-         (add-before 'configure 'patch-configure
-           (lambda _
-             ;; XXX: The 'configure' script doesn't handle '-L' flags in the
-             ;; output of 'pkg-config'.
-             (substitute* "configure"
-               (("PKG_CONFIG --libs") "PKG_CONFIG --libs-only-l"))
-             #t))
          (add-after 'build 'build-info
            (lambda _
              (invoke "make" "-C" "doc" "texinfo")