summary refs log tree commit diff
path: root/gnu/packages/cmake.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-11-19 18:44:52 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-11-19 18:47:19 +0200
commit8d16f302e69bb61264e51611d7bad1ce7213ab3f (patch)
tree08fab2ee4a3cb83f5e34a14b17c684694893ac26 /gnu/packages/cmake.scm
parentbf8f33c31fe68ae0479ed6bc2c762dae99318562 (diff)
downloadguix-8d16f302e69bb61264e51611d7bad1ce7213ab3f.tar.gz
gnu: cmake: Only build ccmake on user facing cmake.
* gnu/packages/cmake.scm (cmake-bootstrap)[inputs]: Remove ncurses.
(cmake)[inputs]: Add ncurses.
Diffstat (limited to 'gnu/packages/cmake.scm')
-rw-r--r--gnu/packages/cmake.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index cf3bc406bc..5eef3c8488 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -211,7 +211,6 @@
        ,@(if (hurd-target?)
              '()
              `(("libuv" ,libuv)))       ;not supported on the Hurd
-       ("ncurses" ,ncurses)             ;required for ccmake
        ("rhash" ,rhash)
        ("zlib" ,zlib)))
     (native-search-paths
@@ -330,6 +329,9 @@ and workspaces that can be used in the compiler environment of your choice.")
                                    (string-append doc html))
                  (delete-file-recursively (string-append out html))
                  #t)))))))
+    (inputs
+     `(("ncurses" ,ncurses)             ;required for ccmake
+       ,@(package-inputs cmake-minimal)))
     ;; Extra inputs required to build the documentation.
     (native-inputs
      `(,@(package-native-inputs cmake-minimal)