summary refs log tree commit diff
path: root/gnu/packages/cmake.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-26 12:48:34 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-26 13:39:18 +0100
commit11f4d87756dfc83656021c5aae00850724997ee0 (patch)
treef8410f8f1743120e5d1275815bc0cae9d127f672 /gnu/packages/cmake.scm
parent013c5c23f9c3cc7464841c920c9557741ff5ed1b (diff)
downloadguix-11f4d87756dfc83656021c5aae00850724997ee0.tar.gz
gnu: cmake: Remove bundled LibUV.
* gnu/packages/cmake.scm (cmake-minimal)[source](snippet): Delete
'Utilities/cmlibuv'.
Diffstat (limited to 'gnu/packages/cmake.scm')
-rw-r--r--gnu/packages/cmake.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index ffb2eeba48..ecabc8a763 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -246,7 +246,11 @@ and workspaces that can be used in the compiler environment of your choice.")
               (snippet
                (match (origin-snippet (package-source cmake-bootstrap))
                  ((begin exp ...)
-                  (append '(begin (delete-file-recursively "Utilities/cmjsoncpp"))
+                  ;; Now we can delete the remaining software bundles.
+                  (append '(begin
+                             (for-each delete-file-recursively
+                                       '("Utilities/cmjsoncpp"
+                                         "Utilities/cmlibuv")))
                           exp))))))
     (native-inputs
      `(("curl" ,curl)