summary refs log tree commit diff
path: root/gnu/packages/cmake.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-04-28 15:29:17 +0800
committer宋文武 <iyzsong@gmail.com>2015-04-28 15:45:54 +0800
commit477a752e897c41a08f141d2af724ba817338e914 (patch)
treed4a7f3c90bbae1224dd0e1c38763edd3f9852bc8 /gnu/packages/cmake.scm
parent4ac0d6444d4edf38edc7c07331cf76deb4a506bc (diff)
downloadguix-477a752e897c41a08f141d2af724ba817338e914.tar.gz
gnu: cmake: Update to 3.2.2.
* gnu/packages/cmake.scm (cmake): Update to 3.2.2.
* gnu/packages/patches/cmake-fix-tests.patch: Skip test for BundleUtilities.
Diffstat (limited to 'gnu/packages/cmake.scm')
-rw-r--r--gnu/packages/cmake.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index 1fb9241596..0dbb81bfb8 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -3,6 +3,7 @@
 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
+;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -35,7 +36,7 @@
 (define-public cmake
   (package
     (name "cmake")
-    (version "3.1.3")
+    (version "3.2.2")
     (source (origin
              (method url-fetch)
              (uri (string-append
@@ -43,7 +44,7 @@
                    (version-major+minor version)
                    "/cmake-" version ".tar.gz"))
              (sha256
-              (base32 "1l662p9lscbzx9s85y86cynb9fn1rb2alqg4584wqq9gibxd7x25"))
+              (base32 "0y3w83al0vh9ll7fnqm3nx7l8hsl85k8iv9abxb791q36rp4xsdd"))
              (patches (list (search-patch "cmake-fix-tests.patch")))))
     (build-system gnu-build-system)
     (arguments
@@ -66,7 +67,8 @@
                          "Utilities/cmbzip2/Makefile-libbz2_so"
                          "Utilities/Release/release_cmake.cmake"
                          "Utilities/cmlibarchive/libarchive/archive_write_set_format_shar.c"
-                         "Tests/CMakeLists.txt")
+                         "Tests/CMakeLists.txt"
+                         "Tests/RunCMake/File_Generate/RunCMakeTest.cmake")
                      (("/bin/sh") (which "sh"))))
                  (alist-cons-before
                   'configure 'set-paths
@@ -83,6 +85,7 @@
                                "./configure"
                                (string-append "--prefix=" out)
                                "--system-libs"
+                               "--no-system-jsoncpp" ; not packaged yet
                                ;; By default, the man pages and other docs land
                                ;; in PREFIX/man and PREFIX/doc, but we want them
                                ;; in share/{man,doc}.  Note that unlike