summary refs log tree commit diff
path: root/gnu/packages/cmake.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-16 19:40:49 +0200
committerMarius Bakke <marius@gnu.org>2022-09-16 22:41:22 +0200
commit3cf8b3dc574c5c0e8df1b76b9349db197ba54333 (patch)
treea5082345d3b4a96f7a5f9b1bcb344c1e26dc4772 /gnu/packages/cmake.scm
parent2ca34cc3bbf03bd67eecbcaecfb67823794b807b (diff)
downloadguix-3cf8b3dc574c5c0e8df1b76b9349db197ba54333.tar.gz
gnu: cmake-minimal: Update to 3.24.2.
* gnu/packages/patches/cmake-curl-certificates.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/cmake.scm (cmake-bootstrap): Update to 3.24.2
[source](patches): Use refreshed patch.
(cmake)[version, source]: Remove.
Diffstat (limited to 'gnu/packages/cmake.scm')
-rw-r--r--gnu/packages/cmake.scm23
1 files changed, 3 insertions, 20 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index 7f51c02b8a..151b91bf12 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -152,7 +152,7 @@ using the CMake build system.")
 (define-public cmake-bootstrap
   (package
     (name "cmake-bootstrap")
-    (version "3.24.1")
+    (version "3.24.2")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://cmake.org/files/v"
@@ -160,8 +160,8 @@ using the CMake build system.")
                                   "/cmake-" version ".tar.gz"))
               (sha256
                (base32
-                "0ax83yfis1n74llqhckrbgzcp82pfwx039xs2dgq06nvlivy4ca9"))
-              (patches (search-patches "cmake-curl-certificates.patch"))))
+                "1ny8y2dzc6fww9gzb1ml0vjpx4kclphjihkxagxigprxdzq2140d"))
+              (patches (search-patches "cmake-curl-certificates-3.24.patch"))))
     (build-system gnu-build-system)
     (arguments
      (list
@@ -330,23 +330,6 @@ and workspaces that can be used in the compiler environment of your choice.")
   (package
     (inherit cmake-minimal)
     (name "cmake")
-    (version "3.24.2")
-    (source (origin
-              (inherit (package-source cmake-minimal))
-              (method url-fetch)
-              (uri (string-append "https://cmake.org/files/v"
-                                  (version-major+minor version)
-                                  "/cmake-" version ".tar.gz"))
-              (snippet (match (origin-snippet (package-source cmake-minimal))
-                         (('begin ('define 'preserved-files ('quote x))
-                                  rest ...)
-                          `(begin (define preserved-files
-                                    ',(cons "Utilities/cmelf" x))
-                                  ,@rest))))
-              (sha256
-               (base32
-                "1ny8y2dzc6fww9gzb1ml0vjpx4kclphjihkxagxigprxdzq2140d"))
-              (patches (search-patches "cmake-curl-certificates-3.24.patch"))))
     (outputs '("out" "doc"))
     (arguments
      (substitute-keyword-arguments (package-arguments cmake-minimal)