summary refs log tree commit diff
path: root/gnu/packages/cmake.scm
diff options
context:
space:
mode:
authorPierre-Moana Levesque <pierre.moana.levesque@gmail.com>2019-08-05 22:50:54 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2019-11-15 17:32:27 +0100
commita8446b40295c18ce1fcce66081c828bb391c09c9 (patch)
tree072a89a6b3ee9bfe74e878c6ff99ffa12af26636 /gnu/packages/cmake.scm
parent3403a4201057a9f7b02d332029d0c4f2ba158376 (diff)
downloadguix-a8446b40295c18ce1fcce66081c828bb391c09c9.tar.gz
gnu: cmake: Fix cross-compilation.
* gnu/packages/cmake.scm (cmake-minimal)[inputs]: Move all inputs to ...
[native-inputs]: ... here, except for ncurses.
Diffstat (limited to 'gnu/packages/cmake.scm')
-rw-r--r--gnu/packages/cmake.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index 13252a9486..b9ac84ad7e 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -9,6 +9,7 @@
 ;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2019 Pierre-Moana Levesque <pierre.moana.levesque@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -145,16 +146,17 @@
          (replace 'configure
            (lambda* (#:key (configure-flags '()) #:allow-other-keys)
              (apply invoke "./configure" configure-flags))))))
-    (inputs
+    (native-inputs
      `(("bzip2" ,bzip2)
        ("curl" ,curl)
        ("expat" ,expat)
        ("file" ,file)
        ("libarchive" ,libarchive)
        ("libuv" ,libuv)
-       ("ncurses" ,ncurses) ; required for ccmake
        ("rhash" ,rhash)
        ("zlib" ,zlib)))
+    (inputs
+     `(("ncurses" ,ncurses))) ; required for ccmake
     (native-search-paths
      (list (search-path-specification
             (variable "CMAKE_PREFIX_PATH")