summary refs log tree commit diff
path: root/gnu/packages/cmake.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-08-01 15:49:28 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-08-01 15:49:28 +0200
commit5a7c6d02b287a5134511f139406889dbf965923f (patch)
treeaefeee5d6eb37052a1a755365e79f1828778e74e /gnu/packages/cmake.scm
parent497b2d39427af4aaddbaa8922d4a6a858bbdaee7 (diff)
downloadguix-5a7c6d02b287a5134511f139406889dbf965923f.tar.gz
gnu: emacs-cmake-mode: Do not inherit inputs and outputs from CMake.
* gnu/packages/cmake.scm (emacs-cmake-mode)[native-inputs, inputs, outputs]:
New fields.
[arguments]: End phases on #t.
Diffstat (limited to 'gnu/packages/cmake.scm')
-rw-r--r--gnu/packages/cmake.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index 387456be50..1d8d829ec5 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -9,7 +9,6 @@
 ;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
-
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -212,6 +211,9 @@ and workspaces that can be used in the compiler environment of your choice.")
   (package
     (inherit cmake)
     (name "emacs-cmake-mode")
+    (native-inputs '())
+    (inputs '())
+    (outputs '("out"))
     (build-system emacs-build-system)
     (arguments
      `(#:phases
@@ -219,7 +221,8 @@ and workspaces that can be used in the compiler environment of your choice.")
          (add-after 'unpack 'chdir-elisp
            ;; Elisp directory is not in root of the source.
            (lambda _
-             (chdir "Auxiliary"))))))
+             (chdir "Auxiliary")
+             #t)))))
     (synopsis "Emacs major mode for editing Cmake expressions")
     (description "@code{cmakeos-mode} provides an Emacs major mode for editing
 Cmake files.  It supports syntax highlighting, indenting and refilling of