summary refs log tree commit diff
path: root/gnu/packages/cmake.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-26 13:15:55 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-26 13:39:19 +0100
commitac841750a52e44d68d7f1b02e9507421f3e3824f (patch)
tree77827656758dd3f6dc5162b8d1566e3aadddbe56 /gnu/packages/cmake.scm
parenta51c9c903f9db26a08672c7e19ddddeef1aee6b4 (diff)
downloadguix-ac841750a52e44d68d7f1b02e9507421f3e3824f.tar.gz
gnu: cmake: Fix cross-compilation.
* gnu/packages/cmake.scm (cmake-bootstrap)[native-inputs]: Move everything
except (PACKAGE-SOURCE LIBARCHIVE) ...
[inputs]: ... here.
* gnu/packages/cmake.scm (cmake-minimal)[native-inputs, inputs]: Adjust accordingly.
Diffstat (limited to 'gnu/packages/cmake.scm')
-rw-r--r--gnu/packages/cmake.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index 93a71e1d92..cc4340bbc6 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -197,17 +197,17 @@
            (lambda* (#:key (configure-flags '()) #:allow-other-keys)
              (apply invoke "./configure" configure-flags))))))
     (native-inputs
+     `(("libarchive:source" ,(package-source libarchive))))
+    (inputs
      `(("bzip2" ,bzip2)
        ("curl" ,curl-minimal)
        ("expat" ,expat)
        ("file" ,file)
        ("libarchive" ,libarchive)
-       ("libarchive:source" ,(package-source libarchive))
        ("libuv" ,libuv)
+       ("ncurses" ,ncurses)             ;required for ccmake
        ("rhash" ,rhash)
        ("zlib" ,zlib)))
-    (inputs
-     `(("ncurses" ,ncurses))) ; required for ccmake
     (native-search-paths
      (list (search-path-specification
             (variable "CMAKE_PREFIX_PATH")
@@ -252,10 +252,10 @@ and workspaces that can be used in the compiler environment of your choice.")
                                        '("Utilities/cmjsoncpp"
                                          "Utilities/cmlibuv")))
                           exp))))))
-    (native-inputs
+    (inputs
      `(("curl" ,curl)
        ("jsoncpp" ,jsoncpp)
-       ,@(alist-delete "curl" (package-native-inputs cmake-bootstrap))))
+       ,@(alist-delete "curl" (package-inputs cmake-bootstrap))))
     (build-system cmake-build-system)
     (arguments
      `(#:configure-flags