summary refs log tree commit diff
path: root/gnu/packages/cobol.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-01-30 11:33:18 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-01-30 12:39:40 +0200
commit4cf1acc7f3033b50b0bf19e02c9f522d522d338c (patch)
tree9fd64956ee60304c15387eb394cd649e49f01467 /gnu/packages/cobol.scm
parentedb8c09addd186d9538d43b12af74d6c7aeea082 (diff)
parent595b53b74e3ef57a1c0c96108ba86d38a170a241 (diff)
downloadguix-4cf1acc7f3033b50b0bf19e02c9f522d522d338c.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates
 Conflicts:
	doc/guix.texi
	gnu/local.mk
	gnu/packages/admin.scm
	gnu/packages/base.scm
	gnu/packages/chromium.scm
	gnu/packages/compression.scm
	gnu/packages/databases.scm
	gnu/packages/diffoscope.scm
	gnu/packages/freedesktop.scm
	gnu/packages/gnome.scm
	gnu/packages/gnupg.scm
	gnu/packages/guile.scm
	gnu/packages/inkscape.scm
	gnu/packages/llvm.scm
	gnu/packages/openldap.scm
	gnu/packages/pciutils.scm
	gnu/packages/ruby.scm
	gnu/packages/samba.scm
	gnu/packages/sqlite.scm
	gnu/packages/statistics.scm
	gnu/packages/syndication.scm
	gnu/packages/tex.scm
	gnu/packages/tls.scm
	gnu/packages/version-control.scm
	gnu/packages/xml.scm
	guix/build-system/copy.scm
	guix/scripts/home.scm
Diffstat (limited to 'gnu/packages/cobol.scm')
-rw-r--r--gnu/packages/cobol.scm43
1 files changed, 22 insertions, 21 deletions
diff --git a/gnu/packages/cobol.scm b/gnu/packages/cobol.scm
index c1699b7e3a..a67eef3cd4 100644
--- a/gnu/packages/cobol.scm
+++ b/gnu/packages/cobol.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2017, 2018, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017, 2018, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -22,6 +22,7 @@
   #:use-module (guix licenses)
   #:use-module (guix packages)
   #:use-module (guix download)
+  #:use-module (guix gexp)
   #:use-module (gnu packages dbm)
   #:use-module (gnu packages multiprecision)
   #:use-module (gnu packages ncurses)
@@ -43,21 +44,22 @@
          (base32
           "0x15ybfm63g7c9340fc6712h9v59spnbyaz4rf85pmnp3zbhaw2r"))))
     (arguments
-     '(#:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath="
-                                              (assoc-ref %outputs "out")
-                                              "/lib")
-                               (string-append "JSON_C_CFLAGS=-I"
-                                              (assoc-ref %build-inputs "json-c")
-                                              "/include/json-c"))
+     (list
+       #:configure-flags
+       #~(list (string-append "LDFLAGS=-Wl,-rpath="
+                              #$output "/lib")
+               (string-append "JSON_C_CFLAGS=-I"
+                              (search-input-directory %build-inputs
+                              "/include/json-c")))
        #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'place-cobol85-test-suite
-           (lambda* (#:key inputs #:allow-other-keys)
-             (let ((newcob (assoc-ref inputs "newcob")))
-               (copy-file newcob "tests/cobol85/newcob.val.Z"))))
-         (add-before 'check 'set-TERM
-           ;; Some tests expect a known terminal
-           (lambda _ (setenv "TERM" "xterm-256color"))))
+       #~(modify-phases %standard-phases
+           (add-after 'unpack 'place-cobol85-test-suite
+             (lambda* (#:key inputs #:allow-other-keys)
+               (let ((newcob (assoc-ref inputs "newcob")))
+                 (copy-file newcob "tests/cobol85/newcob.val.Z"))))
+           (add-before 'check 'set-TERM
+             ;; Some tests expect a known terminal
+             (lambda _ (setenv "TERM" "xterm-256color"))))
        #:test-target "checkall"))
     (native-inputs
      `(("perl" ,perl)
@@ -72,10 +74,9 @@
     (build-system gnu-build-system)
     (home-page "https://www.gnu.org/software/gnucobol/")
     (synopsis "Modern COBOL compiler")
-    (description "GnuCOBOL is a free, modern COBOL compiler.  GnuCOBOL
-implements a substantial part of the COBOL 85, COBOL 2002 and COBOL 2014
-standards and X/Open COBOL, as well as many extensions included in other
-COBOL compilers (IBM COBOL, MicroFocus COBOL, ACUCOBOL-GT and others).
-GnuCOBOL translates COBOL into C and compiles the translated code using
-a native C compiler.")
+    (description
+     "GnuCOBOL is a free, modern COBOL compiler.  It implements a substantial
+part of COBOL 85, X/Open COBOL and newer ISO COBOL standards as well as many
+extensions from other COBOL compilers (IBM COBOL, MicroFocus COBOL, ACUCOBOL-GT
+and others).")
     (license gpl3+)))