summary refs log tree commit diff
path: root/gnu/packages/code.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-06-09 20:39:13 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-06-09 20:39:19 +0300
commite1383bfa6a3ab69edaa3e05e7302b73e8d3c5aa5 (patch)
tree523aa5342ff96753f7e04db60d00648469c967ea /gnu/packages/code.scm
parente3de5d6701eb9892f27ca7fc2c816ee3113737b3 (diff)
downloadguix-e1383bfa6a3ab69edaa3e05e7302b73e8d3c5aa5.tar.gz
gnu: universal-ctags: Update to 5.9.20220605.0.
* gnu/packages/code.scm (universal-ctags): Update to 5.9.20220605.0.
[source]: Adjust snippet to preserve newline.
[inputs]: Add pcre2.
Diffstat (limited to 'gnu/packages/code.scm')
-rw-r--r--gnu/packages/code.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index 4432e0b851..b2959aafb2 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -390,7 +390,7 @@ features that are not supported by the standard @code{stdio} implementation.")
 (define-public universal-ctags
   (package
     (name "universal-ctags")
-    (version "5.9.20210509.0")
+    (version "5.9.20220605.0")
     (source
      (origin
        (method git-fetch)
@@ -400,14 +400,14 @@ features that are not supported by the standard @code{stdio} implementation.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "1sq94bnbzr40zwihfnsna759bbak0lw27j0yn12iwpg4xgb4hhwp"))
+         "0mri7m2qsw5pyq1ajapawvxn2cdrzg1vi4w2bdq0z4ws4q03lj7k"))
        (modules '((guix build utils)))
        (snippet
         '(begin
            ;; Remove the bundled PackCC and associated build rules.
            (substitute* "Makefile.am"
              (("^PACKCC = .*")
-              "PACKCC = packcc")
+              "PACKCC = packcc\n")
              (("\\$\\(PACKCC_FILES\\)")
               "")
              (("\\$\\(PEG_SRCS\\) \\$\\(PEG_HEADS\\): \\$\\(PACKCC\\)")
@@ -437,7 +437,7 @@ features that are not supported by the standard @code{stdio} implementation.")
     (native-inputs
      (list autoconf automake packcc perl pkg-config))
     (inputs
-     (list jansson libseccomp libxml2 libyaml))
+     (list jansson libseccomp libxml2 libyaml pcre2))
     (home-page "https://ctags.io/")
     (synopsis "Generate tag files for source code")
     (description