summary refs log tree commit diff
path: root/gnu/packages/code.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-05-23 12:11:40 +0200
committerLudovic Courtès <ludo@gnu.org>2018-05-23 12:14:12 +0200
commitc1e5109b6843d5670bf81678f2697babc9b770c9 (patch)
treef600bca94e211a5fff8c8ba508f82c39b6b51721 /gnu/packages/code.scm
parent9c4dcfaf66d37faeb165e9284f6a57871e96e1ac (diff)
downloadguix-c1e5109b6843d5670bf81678f2697babc9b770c9.tar.gz
gnu: Move 'astyle' to code.scm.
Suggested by Pierre Neidhardt <ambrevar@gmail.com>.

* gnu/packages/pretty-print.scm (astyle): Move to...
* gnu/packages/code.scm (astyle): ... here.  New variable.
Diffstat (limited to 'gnu/packages/code.scm')
-rw-r--r--gnu/packages/code.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index 24398fac91..6dbdf8a232 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -8,6 +8,7 @@
 ;;; Copyright © 2017 Andy Wingo <wingo@igalia.com>
 ;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
 ;;; Copyright © 2018 Pierre Neidhardt <ambrevar@gmail.com>
+;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -570,3 +571,44 @@ Objective@tie{}C, D, Java, Pawn, and Vala).  Features:
 @item Highly configurable - More than 600 configurable options.
 @end itemize\n")
     (license license:gpl2+)))
+
+(define-public astyle
+  (package
+    (name "astyle")
+    (version "2.05")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://sourceforge/astyle/astyle/astyle%20"
+                           version "/astyle_"  version "_linux.tar.gz"))
+       (sha256
+        (base32
+         "0f9sh9kq5ajp1yz133h00fr9235p1m698x7n3h7zbrhjiwgynd6s"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f                      ;no tests
+       #:make-flags (list (string-append "prefix=" %output)
+                          "INSTALL=install"
+                          "all")
+       #:phases
+       (modify-phases %standard-phases
+         (replace 'configure
+           (lambda _ (chdir "build/gcc") #t))
+         (add-after 'install 'install-libs
+           (lambda* (#:key outputs #:allow-other-keys)
+             ;; Libraries are not installed by default
+             (let* ((output (assoc-ref outputs "out"))
+                    (libdir (string-append output "/lib")))
+               (begin
+                 (mkdir-p libdir)
+                 (for-each (lambda (l)
+                             (copy-file
+                              l (string-append libdir "/" (basename l))))
+                           (find-files "bin" "lib*"))))
+             #t)))))
+    (home-page "http://astyle.sourceforge.net/")
+    (synopsis "Source code indenter, formatter, and beautifier")
+    (description
+     "Artistic Style is a source code indenter, formatter, and beautifier for
+the C, C++, C++/CLI, Objective‑C, C#, and Java programming languages.")
+    (license license:lgpl3+)))