summary refs log tree commit diff
path: root/gnu/packages/code.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-06 22:50:31 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-21 18:23:33 +0100
commit0c6ab52243353e3417e5a9733bb089e4771cc86e (patch)
treed4b44c9096a893eac7d20fafc9e1ece582624930 /gnu/packages/code.scm
parent62b8ae1a910d4b89287ead11bd2c18325e660bdf (diff)
downloadguix-0c6ab52243353e3417e5a9733bb089e4771cc86e.tar.gz
gnu: astyle: Install header file, too.
* gnu/packages/code.scm(astyle)[arguments]<phases>{install-libs}: Also
  install header file.
Diffstat (limited to 'gnu/packages/code.scm')
-rw-r--r--gnu/packages/code.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index 7656ee8739..021181bd8f 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -607,8 +607,9 @@ Objective@tie{}C, D, Java, Pawn, and Vala).  Features:
            (lambda _ (chdir "build/gcc") #t))
          (add-after 'install 'install-libs
            (lambda* (#:key outputs #:allow-other-keys)
-             ;; Libraries are not installed by default
+             ;; Libraries and includes are not installed by default
              (let* ((output (assoc-ref outputs "out"))
+                    (incdir (string-append output "/include"))
                     (libdir (string-append output "/lib")))
                (define (make-so-link sofile strip-pattern)
                  (symlink
@@ -616,6 +617,9 @@ Objective@tie{}C, D, Java, Pawn, and Vala).  Features:
                   (regexp-substitute #f
                                      (string-match strip-pattern sofile)
                                      'pre)))
+               (mkdir-p incdir)
+               (copy-file "../../src/astyle.h"
+                          (string-append incdir "/astyle.h"))
                (mkdir-p libdir)
                (for-each (lambda (l)
                            (copy-file