summary refs log tree commit diff
path: root/gnu/packages/code.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-11-03 06:18:36 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-11-03 06:38:55 +0100
commit104264cd3a49fab79cdb55585922e6694e109b17 (patch)
treea50dbafea1e1e50770f2d608eeecfc6ed62d4cec /gnu/packages/code.scm
parent38e10e08b3b45f44e53f09b1ff90755e3f95c9eb (diff)
downloadguix-104264cd3a49fab79cdb55585922e6694e109b17.tar.gz
gnu: makefile2graph: Don't use unstable tarball.
* gnu/packages/code.scm (makefile2graph)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/code.scm')
-rw-r--r--gnu/packages/code.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index f0943c6990..67a2f80a00 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -515,14 +515,15 @@ produce colored output.")
   (package
     (name "makefile2graph")
     (version "1.5.0")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/lindenb/" name
-                                  "/archive/v" version ".tar.gz"))
-              (sha256
-               (base32
-                "0h1vchkpmm9h6s87p5nf0ksjxcmsxpx8k62a508w428n570wcr4l"))
-              (file-name (string-append name "-" version ".tar.gz"))))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/lindenb/makefile2graph.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1gjfk3d8qg3cla7qd2y7r9s03whlfwy83q8k76xfcnqrjjfavdgk"))))
     (build-system gnu-build-system)
     (arguments
      '(#:test-target "test"