summary refs log tree commit diff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2021-02-06 21:13:52 -0500
committerTimothy Sample <samplet@ngyro.com>2022-03-19 13:33:06 -0600
commit892aac72a2e90682fe53075b03967217afb3df08 (patch)
treef2d83795de06ac1ae081a4ad5ee7b75c08f85952 /gnu/packages/commencement.scm
parent0db2a6e74952ee2c99d47e9580aac9d7fe657b16 (diff)
downloadguix-892aac72a2e90682fe53075b03967217afb3df08.tar.gz
gnu: gash-utils: Update to 0.2.0.
* gnu/packages/patches/gash-utils-ls-test.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
* gnu/packages/shells.scm (gash-utils): Update to 0.2.0.
[source]: Remove patch and Guile 3.0 snippet.
* gnu/packages/commencement.scm (gash-utils-boot)[source]: Do not
modify parent value.
[arguments]: Add "env" to the list of scripts to create in the
'pre-configure' phase; add the "gash-utils" module directory in the
'configure', 'build', and 'install' phases.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm17
1 files changed, 7 insertions, 10 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index fd3a9c37e7..405cbedd71 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -175,10 +175,6 @@ pure Scheme to Tar and decompression in one easy step.")
   (package
     (inherit gash-utils)
     (name "gash-utils-boot")
-    (source (origin
-              (inherit (package-source gash-utils))
-              (patches '())
-              (snippet #f)))            ;discard snippet for Guile 3.0 support
     (arguments
      `(#:implicit-inputs? #f
        #:tests? #f
@@ -210,9 +206,9 @@ pure Scheme to Tar and decompression in one easy step.")
                              (substitute* target
                                (("@UTILITY@") script))))
                          '("awk" "basename" "cat" "chmod" "cmp" "command"
-                           "compress" "cp" "cut" "diff" "dirname" "expr"
-                           "false" "find" "grep" "head" "ln" "ls" "mkdir"
-                           "mv" "printf" "pwd" "reboot" "rm" "rmdir"
+                           "compress" "cp" "cut" "diff" "dirname" "env"
+                           "expr" "false" "find" "grep" "head" "ln" "ls"
+                           "mkdir" "mv" "printf" "pwd" "reboot" "rm" "rmdir"
                            "sed" "sleep" "sort" "tar" "test" "touch" "tr"
                            "true" "uname" "uniq" "wc" "which"))
                (format #t "Creating scripts/[.in~%")
@@ -222,9 +218,10 @@ pure Scheme to Tar and decompression in one easy step.")
                (delete-file "scripts/template.in")))
            (replace 'configure
              (bootstrap-configure "Gash-Utils" ,(package-version gash-utils)
-                                  '("gash") "scripts"))
-           (replace 'build (bootstrap-build '("gash")))
-           (replace 'install (bootstrap-install '("gash") "scripts"))
+                                  '("gash" "gash-utils") "scripts"))
+           (replace 'build (bootstrap-build '("gash" "gash-utils")))
+           (replace 'install
+             (bootstrap-install '("gash" "gash-utils") "scripts"))
            ;; XXX: The scripts should add Gash to their load paths and
            ;; this phase should not exist.
            (add-after 'install 'copy-gash